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Chapter 1
Internet and e-mail
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Internet


It’s a large network of networks that covers
the whole world and enables millions of
computers from different organisations
and people to communicate globally.
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Description of Internet


The term Internet refers
to global interconnection
of computer networks for
the purpose of
communication and
resource sharing. Figure
left shows how
computes and computer
networks are
interconnected to form
5
the Internet.

Development of Internet (1969)


In 1969, a research body in USA (ARPA)
Advance Research Project Agency set up
a computer network that connected for
universities and was given the name
ARPANET. ARAP’s goal was to allow
multiple users to send and receive
information at the same time.
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Development of Internet (1973-1981)


By 1973, e-mail was the most common
service on the Internet. By 1981, many
people had seen the importance of
computer networking and the Internet.
ARAPnet formed the backbone on which
many organisations started connecting to,
hence expanding it.
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Development of Internet (1987-1994)


By 1987, the Internet boasted of 10,000
host computers. As the importance of
Internet grew, businesses spent billions of
dollars to improve it in order to offer batter
services to their clients. By 1994, 3 million
computers were connected to Internet.
Today the Internet has grown and covered
the whole world.
8
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Importance of Internet


The importance of Internet can be seen
through its contribution to;
Research

activities
News and information dissemination
Leisure
Communication
Business Transaction etc.
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Internet Connectivity Requirements
Telecommunication facilities
 Satellite transmission
 Modem
 Wireless telecommunication
 Internet Service Providers (ISP’s)
 Internet Software
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Telecommunication facilities


Internet relies on telecommunication
facilities like telephone lines, telephone
exchange station and satellite
transmission in order to cover the whole
world. Therefore a computer is connected
to the external world through a telephone
line and has to dial a remote computer on
the net to establish connection for data
transfer.
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Satellite transmission


Intercontinental transfer of
data is achieved by having
satellite base stations
transmitting the data through
a wireless uplink channel to
the satellite. The satellite then
sends the data signal to the
base station on another
continent where it is picked
up and sent to telephone
exchanges for transfer to the
destination computer. Figure
left shows a logical local and
intercontinental connectivity.
12
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Modem


It’s a special digital to analog interface
card that changes data from digital to
analog so as to be transmitted on
telephone lines and on receiving end the
data is changed from analog to digital for
computer to understand.
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Wireless telecommunication


With the dynamic growth in mobile
communication and computing, it is now
possible to access Internet using devices such
as mobile phones, PDAs and notebook PCs.
Heard about Wireless Fidelity to a hotspot?
Global system for mobiles (GMS) provides a
wireless connectivity to mobile devices users
known as General Packet Radio Service
(GPRS).
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Internet Service Providers (ISP’s)


They are companies that offer Internet
Services to end users. They provide the
Internet services to end users at a fee.
Examples of ISP in Kenya include;
 Swiftkenya
 Africaonline
 Todays

online
 Wananchi online
 Interconnect
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Internet Software


Internet software help facilitate your
access to Internet. To achieve
communication between computers
special software called Protocol is
needed.

There are two types of protocols used
with Internet.
16
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Types of protocols


Transmission Control Protocol (TCP) – it
governs how data is transferred from one
computer to the next.



Internet Protocol (IP) – it determines the
addressing system on the Internet.
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Internet Service 1


E-mail – this is the exchange of electronic
letters, data and graphics on the Internet.



Electronic Learning (E-learning) – this is
learning through interaction with special
programs on the computer.



Internet fax – Internet provides you with
complete fax facilities from your computer.
18
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Internet Service 2


Electronic Commerce (e-commerce) – it’s
a commercial activity that takes place by
digital processes over a computer network,
usually the Internet between and among
entitles in the private sector, government
and members of public i.e. the buying and
selling of goods and services over the
Internet.
19

Internet services 3
Instant messaging – this is a more enhanced
messaging service that allows two or more
people to communicate directly. To get the
services, you must first register with an instant
messenger such as Yahoo! Messenger.
 Newsgroups – are organized groups of Internet
users who wish to share ideas and interests.
Once you join a newsgroups, you can
participate in discussion forums and debates.
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Internet Service 3


World Wide Web (WWW) – in order to connect a
network to the Internet, the local area network needs
an Internet server. This server is given the name world
wide wed (www) and has all the information that
others on the Internet access. Individuals and
organisations establish sites where their web
documents can be placed for easy access by external
world. These sites are called websites and each has
a special address called Uniform Resource Locater
(URL) that is used to access them
21

Web portal
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Accessing the Internet


Applications that
enable a user to
access the Internet
are called Web
browsers e.g.
Netscape Navigator,
Internet Explorer,
Mozilla browser etc.
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Login/Sign In


To access a website, type the full address of
the website in the address bar then press
enter key. Some websites allow free access
to all their pages by all visitors. However
others require people to be members hence
a new visitor has to register (sign up). The
registration process gives the visitor a user
name, pass word that can be used to sign
in or log on the website for each visit.
24

12

Surf/Browse


Surfing /Browsing is the process of
accessing Internet resources like web
pages and website.
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Parts of Internet Explorer window
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Uniform Resource Locator


The Uniform Resource Locator (URL), simply
referred to as the web address, connects the
user to a particular website. The URL has two
basic parts.
– standard used to connect to the resource
e.g. hypertext transfer protocol (http://) and file
transfer protocol (ftp://). For example, if you type
http://www.google.co.ke, Google home page is
displayed.
 Domain name – name of the web server where the
resource is located.
27
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Navigation toolbar


The navigation toolbar (Figure below), consists
of buttons you can easily use to navigate the
web. These include; back, forward, refresh,
home, search and stop

28
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Functions of each button on the navigation toolbar 1






Back – returns the browser to the immediate
former web page.
Next – moves the browser to the next web page in
case a person had clicked the back button.
Stop – is used to stop loading the current web
page.
Refresh – is used to reload a web page after
failuring the current attempt.
Home – takes the user to the first page (the home
page) of the default website.
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Functions of each button on the navigation toolbar 2







Search – enables a person to search for
information on the website.
Favourites – displays all links bookmarked to be
revisited later.
History – displays the websites that were visited in
the recent past.
Mail – is used to view and send e-mails.
Print – is used to print web pages.
Go – is used to load the website whose address is
in the address bar.
30
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Adding a website to favorites


Bookmark those
web pages that you
are likely to revisit by
adding them to the
favorite.
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How to use favorites


To bookmark a site;
1.
2.
3.



On the Favorites menu, click “Add to Favorites”
Type or click “OK” to accept the name of the
new favorite.
To make the site available off-line, check
“Make available off-line”.

To view or visit your favorite later;
1.
2.
3.

Open the Windows Explorer.
Locate the favorites folder and open it.
Click the favorite you wish to view.

32
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Hyperlinks and Search Engines


A Hyperlink is a text or picture on an
electronic document, especially web page
that causes web pages to open when the
link is clicked.
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Search Engine


It’s a program that
searches documents
for specified keywords
and returns a list of the
documents where the
keywords were found.
The common search
engine includes;
Google, Yahoo, MSN
etc.
34

17

Downloading


After searching and
finding information on
the net, you may want
to save the information
locally on your
computer. The process
of transferring
information from a
remote computer to a
local storage is called
downloading.
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Printing a web page
1.

2.

3.
4.

Click “Print” button
on the “Navigation”
toolbar. (Print
dialog box is
displayed).
In the “General” tab,
select a printer
which you want to
use.
Set other options.
Click “Print” button.

36
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Electronic Mail (E-mail)


Electronic mail refers to the sending and
receiving of electronic letters and
documents on the Internet.
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E-mail Software


E-mail Software falls
under communication
software that are
designed to help the
user to read and send
individual text
documents on the
Internet so long as
the sender and
receiver have an email address.
38
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E-mail Facilities


Mails



File Attachment



On-line meeting



Telephone messages



Contact Management
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Mails 1


Checking Mail – in order to check mail the
user has to open the e-mail account by
providing the correct user name and
password. In e-mail account, click the
Inbox command to view a link list of all
received mails.



Compose a mail – composing implies
writing. To compose a message, click the
compose command.

40
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Mails 2


Send mail – to send mail, type the correct
e-mail address of the recipient in to; text
box, type four letter then click send
command.



Forward mail – a received mail can be
forwarded to another recipient. After
reading click the Forward command and
then provide the address of the recipient.
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Checking for mails in Yahoo


The use Yahoo mail, you first sign up for
an e-mail account. Yahoo assigns each
user a unique user name referred to as an
ID and a password.

42
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How to check an e-mail in Yahoo
1.

2.

3.

4.

Sign in using your
“ID” and “password”.
Click “Check mail”
button then “Inbox”
In the “Inbox” list
(figure left), click the
subject of the mail to
read.
Read the mail. Open
an attachment if any.
43

How to check an e-mail in Outlook Express
1.

Launch “Outlook
Express” from the
taskbar.

2.

On the Folders list,
click “Inbox”

3.

Read the mail. Open
an attachment if any.
44
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E-mail compose window
1.

A typical e-mail compose window has three basic
elements;
Header; the e-mail header is made up of the following
parts;




2.
3.

Addresses of the recipients; the e-mail recipients can be more
than one.
Subject; presents the topic of the message.
Attachment; files attached from other programs such as Word
processors and spreadsheets.

Message; this is the content of the e-mail. It is typically
short and to the point. It may include text and graphics.
Signature; the signature provides additional
information about the sender such as full name,
45
address and telephone number.

E-mail address format 1


1.
2.
3.
4.
5.

Just like the normal postal address, an e-mail address
determines the destination of the e-mail sent. A typical e-mail
address would look like this;
takangaroo1031@gmail.com
takangaroo1031 is the user name and is usually coined by
the user during e-mail account registration.
@ is the symbol for “at” which separates the user name from
the rest of the address.
gmail.com is the name of the host computer in the network i.e.
the computer on which the e-mail account is hosted.
The period “.” is read as dot and is used to separate different
parts of the e-mail address.
com identifies the type of organisation offering a particular
service(s) and is called the domain, meaning it is a
46
commercial institution.
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Other commonly used domains
Domain Type
.edu

Educational institution

.gov

Government institution

.org

Non-profit making organization

.mil

Military organization

.net

An institution or organization providing
networking services
An academic institution

.ac

47

Other types of domain


Sometimes a two letter extension is added after
the domain name to show the country where
the site is located.
e.g. ta19791031@yahoo.co.jp
the domain .jp stands for Japan. Other domain
names include .ke (Kenya), .uk (United
Kingdom), .ug (Uganda), .tz (Tanzania), .au
(Australia) etc.
48
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How to composing and sending an email


To compose an e-mail
in either in Yahoo mail
or Outlook Express;
1.
2.

3.

4.
5.

Click the “Compose”
button.
Type the recipient
address or get it from the
address book.
Type in the subject of the
message as shown in
Figure left.
Type in the message in
the message box.
Click the “Send” button.
49

File Attachment


E-mail software enables a person to attach
other files like pictures, music, movies
Clips etc. To an e-mail for sharing with
others before sending. The source of
attached files can be from the hard disk or
other storage devices.

50
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How to attaching files into an e-mail
1.

2.

3.

Click the “Attachment”
button on the toolbar.
In the Dialog box that
appears, select the
file(s) to attach.
Click “Attach” button to
attach the files.

NB; An attachment text box
is automatically added
below the subject.
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On-line meeting


It’s possible to hold on-line meeting with
people by sending mails to them e.g. Online interviews may involve a person
sending electronic mail composed of
interview questions to a recipient who can
read and answer back.

52

26

Telephone messages


Wireless Access Protocol (WAP) makes it
possible to send e-mail to a mobile
handset and a mobile message to e-mail
account.
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Contact Management


Most mails programs allow the user to
develop an address book which holds
contact information like e-mail address of
different people.

54
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How to add a contact in Outlook express
1.
2.
3.

4.

5.

From “Tools” menu.
Click “Address Book”.
In the “Address Book”
window, click the “New
Contact” button.
Enter the contact details
including the e-mail
address (figure left).
Click the “Add” button to
add the contact into the
list, then close the
address book.
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How to add a contact in Yahoo mail
1.

From “CONTACT”
menu

2.

Click the “Add New
Contact”

3.

Enter other contact
details.

4.

Click “SAVE” button.
56
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Accessing Information on Emerging Issues


Internet is a storehouse
of information, presented
in the form of text,
documents, pictures,
sound and even video.
The Internet has a wide
range of information
concerning the issues.
Emerging issues refers
to things like HIV/Aids,
drug Abuse, Moral
issues etc.
57

Review questions 1
1.
2.

3.

4.
5.
6.
7.
8.

Define the term Internet.
Give a brief account of how the Internet has evolved.
Explain three ways in which you can connect your
computer or web-enabled handheld device to the
Internet.
Using illustrations, discuss three types of transmission
media used to connect to the Internet.
Discuss how Wi-Fi and GPRS wireless connectivities
work.
Explain five uses of the Internet.
State three advantages and three disadvantages of the
Internet.
State three advantages of using wireless transmission
media to connect to the Internet.
58
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Answer of review questions 1-1
1.
2.
3.

4.
5.

6.

Global interconnection of computer networks.
Started as a research project in USA by ARPA. Today,
Internet is one of the most popular information service.
Using GSM, GPRS service, Wi-Fi or Satellite.
The student to draw or use conceptual diagrams on
telecommunication lines, satellite or cellular (wireless) media.
GPRS is a GSM packet switching services while Wi-Fi
(wireless fidelity) is a long range radio connectivity standard
for mobile devices used to connect to Internet at hot spots.
Some uses of Internet include;
A) World wide web
B) Electronic mail
C) Instant messaging
59
D) E-commerce, e-learning and Newsgroup.

Answer of review questions 1-2
7.

Advantages of Internet:
A)
B)
C)
D)

Efficient communication
Availability of information
Cost saving
Socialisation, etc.

Disadvantages of Internet:
A)
B)
C)

8.

Setup cost may be prohibitive.
Security to data and information.
Inequality in society

Allow mobility
Ease of setup
Not quite expensive to setup
Do not take any physical space.
60
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Review questions 2
1.
2.
3.
4.
5.
6.
7.
8.
9.

State three measures you can take to have a targeted search
of Internet content.
Define the term “Internet blog” and list four types of blogs.
In what circumstances would you choose to view a document
as HTML instead of downloading it?
Explain how you would open a document in its original
application without downloading it.
Explain how you would send one e-mail to may recipients once.
Describe the three parts of an e-mail.
List three examples of e-mail client.
Differentiate between replying and forwarding and e-mail.
Explain how you would send an e-mail that includes photos.61

Answer of review questions 2
1.

2.
3.
4.
5.
6.

Identify a search engine.
Enter keywords.
Use quotation marks to identify
keywords.
Website that contains personal
information.
When not sure of its integrity or
source.
Right click then “Open target as…”.
Mailing group list.
Header (address, subject,
attachment)
Message
Signature

7.

8.

9.

Email
Yahoo! Mail
Endora
Microsoft Express.
Replying means sending
back feedback to the sender
while forward is mailing a
received mail to a third party
recipient.
Add file attachments the
photos should be in a jpeg.
or tif. format.
62
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Review questions 3
1.

Outline the procedure for creating an email in Yahoo mail or Outlook express.

2.

Explain how you add a contract into an
address book.
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Answer of review questions 3
1.

Composing and
sending e-mail.
1.
2.

3.
4.
5.

Click the compose
button.
Type the recipient
address or get it from
the address book.
Type in the subject of
the message.
Type in the message
in the message box.
Click the Send button.

2. Outlook express:
1. From “Tools” menu, click
“Address Book”.
2. In the “Address Book” window,
click the “New Contact” button.
3. Enter the contact details
including the e-mail address.
4. Click the “Add” button to add
the contact into the list, then
close the address book.

Yahoo mail:
1. Click the e-mail address of the
sender.
2. Click “Add” to contacts button.
64
3. Enter other contact details.
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Revision questions 1
1.
2.
3.

4.
5.
6.
7.
8.

Define the term Internet.
Explain the term web page format.
Explain the following Internet address
http://www.google.com in reference to the
structure of a URL.
Define the term Internet telephony.
What is the World Wide Web (www)?
What is a browser?
Explain the process of loading a website.
Explain four uses of e-mail software.
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Answer of revision questions 1-1
1.

2.
3.

4.

It is a network of networks that covers nearly the
whole world and enables transfer of messages,
data and information across continents.
A hypertext page prepared to display content on
the web.
http – hypertext transfer protocol.
www – world wide web.
Google – name of computer with web content.
.com – commercial organisation.
Transmission of voice data over the Internet.
66
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Answer of revision questions 1-2
4.

5.
6.

7.

A virtual space on the Internet that allows web
pages and sites to be accessed. Interlinked
pages formatted in virtual language.
Software that allows viewing of web content.
Start the browser software like Internet
Explorer. Type the URL address of the web
page you wish to access in the address bar
then press the Enter key to load the website.
Sending/receiving text and attachments.
Sending fax.
Keeping address book.
Mobile mail to mobile devices.
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Revision question 2
1.
2.

3.
4.
5.
6.
7.
8.

What is file download? Explain the procedure.
Explain the meaning of the word hyperlink.
Give three steps that you would follow to search for
information on the web.
What would you do if a website refused to load in the browser
on the first attempt?
What is a search engine?
Explain the meaning of the term Internet Service Provider
(ISP).
What three things apart from the computer are needed for one
to be connected to the Internet?
What is a protocol? Write th3e following in full: TCP/IP, HTML,
68
HTTP and ftp.
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Answer of revision questions 2-1
1.

Downloading or saving files from remote hosts on the Internet
on to your computer.


2.
3.
4.
5.

Procedure
i. Right click the link to the file.
ii. Select the “Save” target as command.
iii. Select a folder and name for the file in the “Save as” dialog box then
click “Save”.

A text or a picture that is a link to another webpage on the
Internet.
Check newsrooms for latest information on the topic then use a
search engine to look for links to the information required.
Click the refresh button on toolbar.
A search engine is a special program that collects and stores
links to information websites allowing user to search its
69
database for them.

Answer of revision questions 2-2
6.
7.
8.

9.

A company that offers Internet services to end users.
Modems, Internet software, Internet service provider,
telecommunication lines, TCP/IP protocols.
Modem – term stands for modulator demodulator. A
device that enables telecommunication use telephone
lines.
Are special communication rules that govern sending
and receiving of messages by computers on a network.






protocol (TCP).
Internet protocol (IP).
Hypertext markup language (HTML).
Hypertext transmission protocol (HTTP).
File transfer protocol (fip).

70
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Practical activity 1
1.

If the computers in the laboratory are
connected to the Internet check on the
following.
a.
b.

2.

The TCP/IP address of one of the computer
The DNS server address of your service
provider.

Using a laptop or mobile phone that is
configured with GPRS and a Bluetooth or
Wi-Fi connectivity, establish an Internet
connection.
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Practical activity 2
1.
2.
3.

4.

Launch Internet explorer and use it to visit one of the
academic sites such as a high school, colleges or universities.
Download a PDF file from the academic site you have chosen.
Create and send an e-mail to a friend inviting him/her for a
birthday party to be held on the coming Sunday. The mail
should include a picture of a cake.
Using a search engine, find information on the historical
development of the Internet. Copy and paste the material you
get in a five page Microsoft Word document that has the
following structure;
1.
2.
3.
4.
5.

Title page.
Introduction.
Historical development of the Internet.
Future trends.
Conclusion.

Edit, format and save the document as History.doc

72
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Chapter 2
Data security and controls

73

Data and information security


Protection of data and information against
unauthorised access or modification.



Denial of data and information to
unauthorised users.



Provision of data and information to
authorised users.
74
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Data security core principles


The three core
principles of data
security also referred
to as information
security are
confidentiality,
integrity and
availability as shown
in CIA Triad diagram
figure left.
75

Data and Information Privacy


Private data – refers to that or information that
belongs to an individual and must not be
accessed by or disclosed to any other person
unless with direct permission from the owner.



Confidential data – this is data or information
held by a government or organisation about
people. The data must be protected against
unauthorised access or disclosure.
76
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Security threats and control measures
Viruses
 Unauthorised access
 Computer errors and accidental access
 Theft
 Computer crimes
 Fraud
 Sabotage
 Alteration
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Viruses


A computer virus is a destructive program
that attaches itself to other files and
installs itself without permission on the
computer when the files are opened for
use.

78
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Types of Computer Viruses







Boot Sector – they destroy the booting information on
storage devices.
File Virus – attach themselves to files.
Hoax Virus – come as e-mail with an attractive subject
and launches itself when e-mail is opened.
Tronjans – they perform undesirable activities in the
background without user knowledge.
Worms – it sticks in the computer memory.
Back doors – may be a Trojan or Worm that allows
79
hidden access to a computer system.

Sources of viruses


Contact with contaminated systems.



Pirated software.



Infected proprietary software.



Freeware and shareware.



Updates of software distributed via networks.
80
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Virus symptoms
Unfamiliar graphics.
 Programs taking long to load.
 Unusual error messages occurring more
frequently.
 Less memory available than usual.
 Files/Programs disappearing mysteriously.
 Changes to disk volume IDs.
 Disk access seems excessive for simple
task.
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Control measure against Virus


Install the latest version of anti-virus
software on the computers.



Avoid foreign diskettes in the computer
room.



Avoid opening mail attachment before
scanning them for virus.
82
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Unauthorised access


Physical access to computer system should be
restricted to ensure that no unauthorised person gets
access to the system. Unauthorised access may take
the following forms;
– this is tapping into communication
channels to get information.
 Surveillance (monitoring) – this involves where a person
may keep a profile of all computer activities done by another
person or person. The gathered information is used for other
illegal work.
 Industrial Espionage – spying on your competitor to get
information that you can use to counter or finish the
83
competitor
 Eavesdropping

Control measure against unauthorised access


Encrypt the data and information during transmission.



Reinforce the weak access points like doors and
windows with metallic grills and burglar alarms.



Enforce network security measures.



Use file passwords.



Use of finger print identification.



Keep computer room closed when nobody is using84it.
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Computer errors and accidental access


Errors and accidental access to data and
information may be as a result of people
experimenting with features they are not
familiar with. Also people might make
mistake by printing sensitive reports and
unsuspecting give them to unauthorised
person.

85

Control Measures against
computer errors and accidents


Give various file access privileges and
roles to the end users and technical staff
in the organisation.



Set up a comprehensive error recovery
strategy in the organisation.
86
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Theft


Theft plays a significant role in the loss or
damage of data. Theft of data happens
within an organisation with authorised
personnel stealing data for one reason or
another.

87

Control against Theft
Employ guards to keep watch over data
and information centres and backup.
 Burglary proofs the computer room.
 Reinforce weak access points like the
windows, doors with metallic grills.
 Create backups in locations away from
main computing centre.


88
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Computer crimes









Trespass – this is the act of gaining access or entering
into a computer system without legal permission.
Cracking – this refers to the use of guess work over
and over again, by a person until he/she finally
discovers a weakness in the security policies or codes
of software.
Hacking – this refers to intentionally breaking of codes
and passwords to gain unauthorised entry to computer
system data and information files.
Tapping – in this crime, a person sends an intelligent
program on a host computer that sends him
information from the computer.
Piracy – this refers to making illegal copies of
89
copyrighted software, information or data.

To eliminate Piracy


Make software cheap, enough to increase
affordability.



Use licenses and certificates to identity
originals.



Set installation password to deter illegal
installation of software.
90
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Fraud


It refers to the use of computer to cheat
other people with the intention of gaining
money or information.
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Sabotage


This is illegal destruction of data and
information with the aim of crippling
service delivery or causing great loss to an
organisation.

92
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Alteration


This is illegal changing of data and
information without permission with the
aim of gaining or misinforming the
authorised users.
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Information system failure


Some of the causes of computerized
information system failure include;
 Hardware

failure due improper use.
 Unstable power supply as a result of
brownout or blackout and vandalism.
 Network breakdown.
 Natural disaster.
 Program failure.
94
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Control measures against hardware failure


Protect computers
against brownout or
blackout which may
cause physical
damage or data loss
by using surge
protectors and UPS
such as the one
shown on figure left.
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Detection and protection against computer crimes 1




Audit Trial – this refers to careful study of an
information system by experts in order to establish or
find out all the weakness in the system that could lead
to security threats and weak access points for crimester.
Firewalls – a firewall is a device or software system
that filters the data and information exchanged
between different networks by enforcing the host
network access control policy. Firewall monitor and
control access to and from protected networks.
96
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Detection and protection against computer crimes 2


Log Files – they are special system files
that keep a record (log) of events on the
use of the computers and resources of the
information system. The information
system administrator can therefore easily
track who accessed the system, when and
what they did on the system.
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Detection and protection against computer crimes 3


Data encryption – data transmitted over a network can
be protected from unauthorised access by mixing it up
into a form that only the sender and receiver can be
able to understand by reconstructing the original
message from the mix.

98
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Difficulty in detection and
prevention of computer crimes


The crime might be complex.



It’s not easy to find clear trail of evidence leading
to the guilty party e.g. No finger prints.



There are no witness.



Few people in management and law
enforcement know enough about computers to
prevent the crime.

99

Laws governing protection of information
Data and information should be kept secure
against loss or exposure.
 Data and information should not be kept longer
than necessary.
 Data and information should be accurate and
update.
 Data should not be transferred to other
countries without the owner’s permission.
 Data and information should be collected, used
and kept for specified lawful purposes.
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Revision questions 1
1.
2.
3.
4.

5.
6.
7.
8.
9.
10.
11.

Differentiate between private and confidential data.
Why is information a useful resource?
Explain any three threats to data and information.
Give two control measures you would take to avoid unauthorized
access to data and information.
Explain the meaning of industrial espionage.
Differentiate between hacking and cracking with reference to
computer crimes.
What reasons may lead to computer fraud?
Explain the term “information security”.
Why would data and information on an externally linked network not
be said to be secure even after burglar proofing a room?
How can piracy be prevented in regard to data and information?
Define a computer virus.
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Answer of revision questions 1-1
1.
2.
3.

4.

5.

Private data –belongs to individual and held by him/her.
Confidential data – held by Government or organisation.
Because of its importance in transactions, sharer ability and high
value attached to it.
Unauthorised exposure.
Unauthorised access.
Destruction by natural calamities.
Fraudsters and computer crimestars.
Keep data and information in well secured and restricted places.
Use passwords and access permission policies to control access to
the data.
Use firewall to enforce security policy.
Audit trials to identify threats to data and information.
The stealing of data and information for commercial gain and to
cripple competitors.
102

51

Answer of revision questions 1-2
6.

7.
8.
9.
10.
11.

Hacking – breaking security codes.
Cracking – looking for weak access points in software
in order to get access to data and information.
For economic gain, Ego, etc.
Is the ensuring of safety of data and information
against threats.
Access can be made through the network.
Enforce copyright laws and other regulatory frame
works.
A virus is a destructive program that installs itself on
storage media causing improper functioning of the
computer system.
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Revision questions 2
1.
2.
3.
4.
5.
6.
7.
8.
9.

Give four general rules that must be observed to keep
within the law when working with data and information.
Explain two types of computer viruses.
What is a program patch? Why are patches important?
Explain measures you would take to protect computers from
virus attacks.
What is data alteration? Explain its effect on data.
How can you control errors related to data and information
entry?
Data and information security has recently become very
important. Explain why?
Explain eavesdropping with reference to computer crimes.
Why use copyright laws for software data and information
104
necessary?
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Answer of revision questions 2-1
1.

2.

3.

4.

Data should not be used for gain unlawfully.
The owner of data and information has a right to know what
data is held by the person/organisation having it.
Do not collect irrelevant and overly too much information for
the purpose.
Data should not be disclosed without the owner’s permission.
Trojans.
Boot sector viruses.
Backdoors.
A software update that when incorporated in the current
software makes it better. They enable better performance of
computer system.
Install anti-virus software. Also restrict foreign storage media
105
in the computer room.

Answer of revision questions 2-2
5.

6.
7.

8.

9.

Changing stored data without permission. This
changes the information inferences from data.
Define roles to various categories of users.
Because information is one of the most
valuable business resource for any
organisation or Government.
Listening to a transmission line to gain a copy
of the message being transmitted.
To deter illegal copying.
106
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Chapter 3
Word processor
Njabini Boys high school
Form two work
107

Introduction


Word processer is an application software
that enable a user to create, save, edit,
format and print text documents.
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Advantages of word processer








It’s faster create documents with word
processor because of the availability of
facilities like formatting and editing features.
Word processor enables users to proof read
and spell check documents on the screen
before they are printed.
Allows multiple copy printing unlike typewriters.
Enables user to store documents for future
editing if need be.
Word processor has superior documents
formatting features.
109

Basic features of word processor






Allow the user to create, save, open and
format files.
Have spell checker, thesaurus and grammar
checker.
Provide headers and footers, indexing.
Have ability to create and import tables, text
and graphics from other programs.
Word wrap – a feature that automatically
moves a word to a new line if it does not fit at
the end of the current line.
110
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Purpose of word processor


Mostly word processor is used for typing
letters, memos, essays, books, reports,
minutes, circulars etc.
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Examples of word processor programs
Microsoft Word.
 Word perfect.
 Word star.
 Amipro.
 PC-Write
 Etc.
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Factors to consider when choosing a W.P.


Type of operating system.



It’s user friendliness.



It’s formatting and edition features.

NB; W.P. stands for Word Processor
113

Starting Microsoft Word 2003
1.

2.

3.

4.

Click on the “Start”
menu.
Point to
“Programs/All
Programs”
Point to “Microsoft
office 2003”
Click “Microsoft
Office Word 2003”
114
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Parts of Microsoft Word 2003 window

115

Explain parts of MS-Word 2003 window 1
1.
2.

3.

4.

Title bar - it displays the title of currently
running application.
Menu bar – provides a drop down list of
commands that one can use to perform a task
e.g. File, Edit, View.
Tool bar – contains buttons and boxes that
allow you to perform tasks more quickly than
using menu bar.
Rulers – used to set tab stops, index
paragraphs, adjust column width and change
page margins.
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Explain parts of MS-Word 2003 window 2
5.
6.
7.
8.
9.

Status bar – displays information about the
program currently running.
Work area – this is the area where you can
enter text or graphical objects.
Scroll bars – allows the user to “pan” the
windows up and that doesn’t fit in the window.
Minimise button – reduces a window to
become a button on the task bars.
Maximise button/Restore – it stretches the
window to cover the entire screen or restore it
to it’s original size respectively.
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MS-Word 2007 window
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Standard toolbar



Standard toolbar contains commands used to
carry out common tasks such as launching a
new document window, opening a file, saving
spelling and grammar checking etc. To see
what the other commands are, just point to the
icon on the toolbar and a text tip will be
displayed showing the function of the icon.
119

Steps of hiding and displaying the toolbars
1.

On the “View” menu.

2.

Point to “Toolbars”

3.

Click the type of
toolbar required to
select it.
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Steps of hiding and displaying the Rulers
1.

Click the “View”
menu.

2.

Click “Ruler” (the
ruler is displayed or
hided on the screen).
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Creating a document


This is the process of typing text in a clean
page.
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Steps of “Creating a document”
1.
2.

3.
4.

On the “File” menu.
Click the “New”
(New document task
pane is displayed).
Click the “Blank
document”.
Click the “OK” button.

NB; shortcut key
Ctrl + N
123

Creating a document based on a template


You may want create a professional or
elegant document such as resume, fax,
letters, memos or reports based on
existing Word templates.
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Steps of “Create a template document”
1.
2.
3.

4.
5.
6.
7.

On the “File” menu.
Click the “New” (New document
task pane is displayed)
In the “Templates” section, click
the “On My Computer”.
(Template dialog box is
displayed).
Select the tab that contain you
want to use.
Select a type of template
document.
Click the “OK” button. (Template
document is displayed)
Create this document.
125

Saving a document


This is the process of making a document
exist in your PC storage media, or on
secondary storage.

NB; PC stands for Personal Computer.
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Saving commands


Save – this command saves the document
without changing the file name or the location.



Save as – this command allows the user to save
the document for the first time, change the file
name or save on a different location.



Saving with password – a password is a string of
characters used to prevent from unauthorised
users. A password is case sensitive always note
the combinations of characters used.
127

Steps of “Save” a document
1.

On the “File” menu.

2.

Click the “Save”.

NB; shortcut key
Ctrl + S
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Steps of “Save as” a document
1.

On the “File” menu.

2.

Click the “Save as” (Save
as dialog box is displayed.)

3.

Select location from save in.

4.

Type file name in the box.

5.

Click the “Save” button.

NB; shortcut key
F12
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Steps of “Save with password”
1.
2.
3.
4.
5.
6.

7.

8.

9.
10.

On the “File” menu
Click the “Save as”
Select the location
Type the file name.
Click the “Tools
Click the “Security options”
(Security options dialog box is
displayed).
Type the password when
opening a document (you need
retype password for confirm).
Type the password to protect
against modification (you need
retype password for confirm).
Click the “OK” button.
Click the “Save” button.
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Closing the current document
1.

On the “File” menu.

2.

Click “Close”

NB; shortcut key
Ctrl + F4
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Opening or retrieving an existing document


This refers to opening a document which
has already been created and saved.
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Exiting from Word


This refers to quitting the MS-Word
program completely
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Steps of “Exit from Word”.
1.

On the “File” menu.

2.

Click the “Exit”.

NB; shortcut key
Alt + F4
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Editing a document


Editing – refers to making necessary
changes to an existing document.
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Steps of “Open” the document 1
1.
2.
3.
4.

5.

On the “File” menu.
Click the “Open” (Open
dialog box is displayed).
Select the location of
the file from “Look in”.
Click the name of the
document you want to
open.
Click the “Open” button.

NB; shortcut key
Ctrl + O
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Steps of “Open” the document 2


You can also open a file from a
recently used file list on the “File”
menu. Word keeps a list of
recently used files on the “File”
drop down menu.

If recently documents isn’t displayed.
1.
2.
3.
4.

On the “Tool” menu.
Click the “Option” (Option dialog
box is displayed).
Click the “General” tab.
Select the “Recently used file list
check box.
137

Selecting with the keyboard







To select one word, move the insertion pointer to
the beginning or end of the word then press
“Shift+Ctrl+Right” or left arrow.
To select one line, press “Shift+Up” or
“Shift+Down” arrow key. Alternatively, move the
insertion point to the end or beginning of the line
then press “Shift+Home” or “End” keys
respectively.
To select an entire page, press “Shift+Page
Down” or “Shift+Page Up”.
To select the entire document, press “Ctrl+A” or
place the cursor at the beginning of the
138
document, then press “Shift+Ctrl+End”.
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Editing features of word processor 1
Typing mode






Insert mode – in this mode when text is
inserted between words or characters it
pushes the existing text away without
replacing it.
Typeover mode – in this mode when text is
typed between words or characters the new
text automatically replaces the existing text
by deleting it. To switch between Typeover
and insert mode you press insert key.
139

Editing features of word processor 2


Find and replace – to search for a
particular word in document, the user
uses the find feature which automatically
locates the word. To replace a word, the
user the replace option.



Proof reading – this refers to checking
whether the document has typographical
or grammar errors.
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How to switch “Typing mode”.


Just type “Insert” key.
This key is one of the
Navigation and
Editing keys. And the
user can confirm
current mode on the
status bar.
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Steps of “Find” function
1.
2.

3.

4.

On the “Edit” menu.
Click the “Find” (Find
and Replace dialog box
is displayed)
Type the word or phrase
to find in the “Find what”
box.
Click the “Find Next”
button.

NB; shortcut key
Ctrl + F
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Steps of “Replace” function
1.
2.
3.
4.

5.

On the “Edit” menu
Click the “Replace” (F&R
dialog box is displayed)
Type word or phrase to find
in the “Find what” box.
Type word or phrase to
replace in the “Replace
with” dialog box.
Click the “Replace” or
“Replace All” button.

NB; shortcut key
Ctrl + H
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Deleting text 1


To delete a
character or a word
from the right to the
left:
1.

2.

Place the insertion
pointer on the
right of the word.
Press the
“Backspace” key.144
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Deleting text 2


To delete a
character to the right
of the cursor
position:
1.

2.

Place the insertion
pointer on the left
of the word.
Press the “Delete”
key.
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Deleting text 3


To delete a block of
text:
1.

Highlight the text
to be deleted.

2.

Press the
“Delete/Del” key.
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Proofreading tools 1








Spelling and grammar checker – this is an inbuilt tool that helps the user to correct spelling
errors and incorrect grammar structures.
Thesaurus – it’s a tool that helps the user’s
finds words or phrases with similar meaning or
opposite meaning to the one selected.
Autocomplete – this is a feature displays a
word when the user types the first few
characters of the word.
Autocorrect – this feature automatically detects
wrongly spelt or capaitalised words and
replaces them.
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Proofreading tools 2


Highlighting/Selecting – it’s the process of
choosing particular areas in the text in order to
apply certain features.



Copy and move text and object – copying
means creating a duplicate of text or an object
in a document.



Undo and Redo – undo feature enables the
user to cancel the most recent editing action
while redo feature repeats the last action.
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Steps of “Spell and grammar” checker
1.
2.

3.

On the “Format” menu.
Click the “Spell and
grammar” (if the
document has any
misspells or grammars,
S&G dialog box is
displayed).
Use this dialog box.

NB; shortcut key
F7
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Parts of “Spell and grammar” dialog box 1
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Parts of “Spell and grammar” dialog box 2
1.
2.
3.
4.

5.

Change – to correct only the highlighted
incorrect word.
Change All – to correct all the occurrences of
the misspelled word.
Ignore – to retain the highlighted and continue.
Ignore All – to retain all the occurrences of the
same word or phrase in the document from
another language.
Add dictionary – to add the word into the
custom dictionary.
151

Step of using “Thesaurus” 1
1.

2.
3.
4.

5.

Select a word or a
phrase you want to
research.
On the “Tools” menu
Point to “Language”
Click the “Thesaurus”
(Research task pane is
displayed).
Choose an alternative
word or phrase you
intend to use as
replacement for the
selected text.
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Steps of using “Thesaurus” 2
5.

6.
7.

To replace a word or a
phrase with an
antonym, select the
word or phrase
enclosed in brackets
Click the drop down list.
Click the “Insert”

NB; shortcut key
Shift + F7
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Steps of turn “Autocomplete” on/off
1.
2.
3.
4.

5.

6.
7.

On the “Insert” menu
Point to “AutoText”
Click the “AutoText”
Select or clear the “Show
AutoComplete tip for
AutoText and dates”
check box.
Type in text in the “Enter
AutoText entries here”.
Click the “Add” button
Click the “OK” button
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Steps of turn “Autocorrect” on/off
1.
2.
3.
4.

5.

6.

On the “Tools” menu
Click the “AutoCorrect
Options”
Click the “Replace text
as you type” check box.
Type the commonly
misspelled word in the
“Replace” box
Type the correct spelling
for the word in the “With”
box.
Click the “OK” button
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Steps of “Selecting” with mouse
1.
2.

3.

To select a word, place the insertion pointer on
the word then, double click it.
To select the entire line, position the mouse
pointer on the left margin until it changes to an
arrow, then click once.
To select a paragraph, place the pointer at the
beginning or end of the paragraph. Notice that
the pointer changes to I-beam. Now drag the Ibeam over the text to be selected and release
the mouse button at the end of the text you
work on.
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Steps of “Copy and move” function
1.
2.
3.
4.

5.
6.

Highlight the text or object.
On the “Edit” menu.
Click the “Copy”
Position the insertion pointer
where you want you copy
text.
On the “Edit” menu,
Click the “Paste.

NB; shortcut key of “Copy”
Ctrl + C
shortcut key of “Paste”
157
Ctrl + V

Steps of “Cut and move” function
1.
2.

3.
4.

5.
6.

Highlight the text or object.
On the “Edit” menu.
Click the “Cut”
Position the insertion pointer
where you want you copy
text.
On the “Edit” menu,
Click the “Paste.

NB; shortcut key of “Cut”
Ctrl + Z
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Steps of “Undo” and Redo”
1.

On the “Edit” menu.

2.

Click the “Undo” or
“Redo”

NB; shortcut key of
“Undo”. Ctrl + Z
shortcut key of
“Redo”. Ctrl + Y
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Formatting document


Formatting refers to applying various
styles or features to enhance the
documents appearance.
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Text formatting


Refers to use of features such as bold,
colour, underline, changing fonts (type,
style) to improve text appearance.
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Types of text formatting








Bolding – this feature makes the text look thick
and darker than the rest of the text in a
document.
Italic – this is to make the text slant forward.
Underline – this is placing of any line style
under text.
Superscript – this describes text that is slightly
higher than other text on a line.
Subscript – this describes text that is slightly
lower than other text on a line.
Change case – this refers to switching between
different cases provided by Microsoft Word. 162
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Steps of “Bold” function.
1.
2.
3.
4.
5.

Highlight the text to be
bold.
On the “Format” menu.
Click the “Font” (Font
dialog box is displayed)
Click the “Bold” of the
“Font style”
Click the “OK” button

NB; shortcut key
Ctrl + B
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Steps of “Italic” function
1.

2.
3.
4.
5.

Highlight the text to be
Italic.
On the “Format” menu.
Click the “Font” (Font
dialog box is displayed)
Click the “Italic” of the
“Font style”
Click the “OK” button

NB; shortcut key
Ctrl + I
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Steps of “Underline” function.
1.
2.
3.
4.

5.

Highlight the text to be
draw the underline.
On the “Format” menu
Click the “Font” (Font
dialog box is displayed)
In the “All text” section,
select the underline type
from drop down list of
“Underline Style”
Click the “OK” button

NB; shortcut key for single
underline. Ctrl + U
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Steps of “Superscript” function
1.

2.
3.
4.

5.

Highlight the text to be
superscript.
On the “Format” menu.
Click the “Font” (Font
dialog box is displayed).
In the “Effects” section,
click the check box of
the “Superscript”
Click the “OK” button.

NB; shortcut key
Ctrl key plus + key
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Steps of “Subscript” function
1.
2.
3.
4.

5.

Highlight the text to be
subscript.
On the “Format” menu.
Click the “Font” (Font
dialog box is displayed).
In the “Effects” section,
click the check box of
the “Subscript”
Click the “OK” button.

NB; shortcut key
Ctrl and Shift keys plus
= key
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Samples of text formatting
Bold

Njabini Boys high
school

Italic

Njabini Boys high school

Underline (Single)

Njabini Boys high school

Superscript

Njabini Boys high school

Subscript

Njabini Boys high school
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Change case


When typing text, there are a number of cases
the user may intend to apply in order to create
contrast within the text. These are
case – all the first characters in a sentence
are in uppercase (capitalised).
 Lowercase – all characters appear in lowercase.
 Uppercase – all characters appear in uppercase.
 Title case – all the first characters of each word in a
sentence appear in uppercase.
 Toggle case – it changes upper cases to lowercases
to and vice versa.
169
 Sentence

Steps of setting a “Change Case”
1.
2.

3.

4.

5.

Highlight the text.
On the “Format”
menu.
Click the “Change
case” (Change case
dialog box is
displayed).
Select the case type
to be applied.
Click the “OK” button.
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Samples of “Change Case”
Sentence case

Njabini Boys high school

lower case

Njabini Boys high school

UPPER CASE

Njabini Boys HIGH SCHOOL

Title Case

Njabini Boys High School

tOGGLE cASE

Njabini Boys hIGH sCHOOL
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Paragraph formatting 1





Text alignment – this refers to how text is lined
up on the page relative to the left, right or
centre of the page.
Indent – indentation refers to moving the text
away from the margin.
Line and character spacing – refers to the
vertical distance between lines of text while
character spacing on the other hand refers to
the space between the characters.
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Paragraph formatting 2






Tab – tabs are used to indent the first line of a
paragraph or create columnar data.
Bullets and Numbering – bullets and numbers
are used to mark steps in a procedure or items
in a list.
Drop caps – it’s a large dropped initial capital
letter in a word or sentence.
Section breaks – break is used to identify
where a section, a columnar or a page ends
and the beginning of next.
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Type of alignments






Lift alignment – text is lined up evenly
along left margin.
Right alignment – text is lined up evenly
along right margin.
Centre alignment – text are centered
unevenly between the left and right
margin.
Justification alignment – text is arranged
evenly along left and right margin.
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Steps of “Left alignments”
1.
2.
3.

4.

5.

Highlight the paragraph to
be left alignments.
On the “Format” menu.
Click the “Paragraph”
(Paragraph dialog box is
displayed)
In the “General” section,
select the “Left” from the
drop down list of
“Alignment”
Click the “OK” button

NB; shortcut key
Ctrl + L
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Steps of “Right alignments”
1.
2.
3.

4.

5.

Highlight the paragraph to
be right alignments.
On the “Format” menu.
Click the “Paragraph”
(Paragraph dialog box is
displayed)
In the “General” section,
select the “Right” from the
drop down list of
“Alignment”
Click the “OK” button

NB; shortcut key
Ctrl + R
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Steps of “Centre alignment”
1.
2.
3.

4.

5.

Highlight the paragraph to
be center alignment.
On the “Format” menu.
Click “Paragraph”
(Paragraph dialog box is
displayed)
In the “General” section,
select the “Centered” from
the drop down list of
“Alignment”
Click the “OK” button

NB; shortcut key
Ctrl + E
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Steps of “Justification alignment”
1.
2.
3.

4.

5.

Highlight the paragraph to
be justification alignment.
On the “Format” menu.
Click “Paragraph”
(Paragraph dialog box is
displayed)
In the “General” section,
select the “Justified” from
the drop down list of
“Alignment”
Click the “OK” button

NB; shortcut key
Ctrl + J
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Steps of “Distributed alignment”
1.
2.
3.

4.

5.

Highlight the paragraph to
be distributed alignment.
On the “Format” menu.
Click “Paragraph”
(Paragraph dialog box is
displayed)
In the “General” section,
select the “Distributed” from
the drop down list of
“Alignment”
Click the “OK” button
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Samples of text alignment
Left alignment

Njabini Boys high school

Right alignment Njabini Boys high school
Centre alignment

Njabini Boys high school

Justification alignment

Njabini Boys high school

Distributed alignment

Njabini Boys high school
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Types of indents


First line indent – this is where the first
line is indent while the other lines are left
along the left margin.



Hinging indent – the whole paragraph is
indent except the first line.



Full indent – the whole paragraph is
indented.
181

Steps of “Full indent”
1.

Highlight the
paragraph to be
indented or position
the cursor any
where in the
paragraph.

2.

Click the “Increase”
or “Decrease Indent”
button of the
formatting toolbar.
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Steps of “First line Indent”
1.
2.
3.

4.

5.
6.

Highlight the paragraph
to be indented.
On the “Format” menu
Click the “Paragraph”
(Paragraph dialog box is
displayed)
In the “Indentation”
section, select the “First
line” from the drop down
list of “Special”.
Select the how far from
margin from “By”
Click the “OK” button.
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Steps of “Hanging indent”
1.
2.
3.

4.

5.
6.

Highlight the paragraph
to be indented.
On the “Format” menu
Click the “Paragraph”
(Paragraph dialog box is
displayed)
In the “Indentation”
section select the
“Hanging” from the drop
down list of “Special”
Select the how far from
margin from “By”
Click the “OK” button.
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Samples of “Indent”
Name of indent
First line indent

Samples

Hanging indent
Full indent
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Steps of change “Line Spacing”
1.

2.
3.

4.

5.

Highlight the text to be
line spacing.
On the “Format” menu
Click the “Paragraph”
(Paragraph dialog box is
displayed)
In the “Spacing” section,
select the spacing
required from the drop
down list of “Line
Spacing”
Click the “OK” button
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Examples of line spacing specifications
1.

1.5 line space.

2.

Single line space.

3.

Double line space.
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Formatting toolbar



As mentioned earlier, the formatting toolbar lets
the user easily format text by clicking the
required format button as shown in above figure
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Steps of setting “Tabs”
1.
2.

3.

4.

5.
6.
7.

On the “Format” menu
Click the “Tabs” (Tabs
dialog box is displayed)
Enter a new value for tab
stop in the box of “Tab
stop position”
Select the type of tab
from “Alignment”
Select the type of leader.
Click the “Set” button
Click the “OK” button
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Setting tabs using the ruler
1.

2.

3.

Click on the “Tab”
button to choose the
required tab type.
Notice that the tab type
keeps on changing as
you click the tab button.
Set the tab stop by
clicking where you want
it to be on the ruler.
Drag the tab stop.
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Types of “Tab”
Button Name

Purpose

Left tab

Text is aligned to the left

Centre tab

Text is centred

Bar tab

Inserts a vertical line at tab stop and
align text to the right of the line

Decimal tab

Text is aligned at decimal character

Right tab

Text is aligned to the right
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Steps of “Bullets and Numbering”
1.
2.
3.

4.

5.

6.

Highlight the text
On the “Format” menu
Click the “Bullets and
Numbering” Bullets and
Numbering dialog box
displayed)
Click the
“Bulleted” ,”Numbered” or
Outline Numbered” tab.
Select the type of bullets or
numbering.
Click the “OK” button. 192

96

Steps of “Drop cap” function
1.

2.

3.

4.

5.

6.

Highlight the first
character in the
sentence.
On the “Format” menu
Click the “Drop Cap”
(Drop Cap dialog box is
displayed)
In the “Position” section,
select a “Dropped” or “In
Margin”
In the “Options” section,
select the font type from
drop down list of “Font”
Click the “OK” button
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Steps of setting “Section breaks”
1.

2.
3.

4.

Position the text
cursor in the
document where the
break is to be
inserted.
On the “Insert” menu
Click the “Break”
(Break dialog box is
displayed)
Click the “OK” button
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Page formatting 1
1.
2.

Page layout – this feature lets the user specify how text
will be placed on the page from the margins.
Page setup – the option lets the user specify the size of
the margins, paper size, paper source and layout.
i. Margins – these are the blank space around the
edges of the page.
ii. Orientations – this refers to the positioning of the
page in relation to text.
a. Landscape orientation – in this text graphics are
printed with longest side of the page placed
horizontally
b. Portrait orientation – in this text and graphics are
printed with the longest side vertically upright.
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Page formatting 2
iv.
v.
vi.

vii.

Page breaks – this identifies the end of one
page and the beginning of the text.
Columns – this refers to dividing of text into
a number of columns.
Headers and footers – headers refers to text
that is placed at the top of every page of a
document. Footers refers to text that is
placed at the bottom of every page.
Page numbering – refers to applying page
numbers on every page of the document.
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Steps of “Page layout”
1.

On the “File” menu.

2.

Click the “Page
Setup” (Page Setup
dialog box is
displayed).

3.

Click the “Layout” tab.

4.

Set layout as desired.

5.
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Click the “OK” button.

Steps of setting “Margins”
1.
2.
3.
4.

5.

On the “File” menu
Click the “Page
Setup”
Click the Margin tab.
In the “Margins”
section, enter the
values for the left,
right, top and bottom
margins in the
respective boxes.
Click the “OK” button
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Steps of setting a “Orientation”
1.
2.

3.
4.

5.

On the “File” menu
Click the “Page
setup” (Page Setup
dialog box is
displayed)
Click the Margin tab.
In the “Orientation”
section, select a
“Portrait” or
“Landscape”.
Click the “OK” button
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Steps of setting a “Paper Size”
1.
2.

3.
4.

5.

On the “File” menu
Click the “Page
Setup” (Page Setup
dialog box is
displayed)
Click the “Paper” tab
In the Paper size”
section, select the
size from drop down
list.
Click the “OK” button
200
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Steps of “Columns” function
1.
2.
3.

4.

5.

Highlight the
paragraph.
On the “Format”
menu
Click the “Columns.
(Columns dialog box
is displayed)
Enter the number of
columns and set the
column width.
Click the “OK” button.
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Steps of “Headers and Footers”
1.
2.

3.
4.
5.
6.

On the “View” menu
Click the “Headers and
Footers” (Headers and
Footers tool bar is
displayed)
Enter text or object in
the header area.
Switch to footer
Enter text or object in
the footer area
Click the “Close” button.
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Steps of “Page numbering”
1.
2.

3.

4.

5.

On the “Insert” menu
Click the “Page
Numbers” (Page
Numbers dialog box is
displayed)
Select the position from
drop down list of
“Position”
Select the alignment
from drop down list of
“Alignment”
Click the “OK” button
203

Inserting footnotes and endnotes


Footnotes and endnotes are used in large
documents to explain, comment on, or
provide references for text in a document.
Footnotes appear at the bottom of the
page while endnotes appear at the end of
a section or the document.
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Steps of “Footnote and endnote”
1.
2.
3.

4.
5.

6.

7.

On the “Insert” menu.
Point to “Reference”
Click the “Footnote”
(Footnote and endnote
dialog box is displayed).
In the location section, click
“Footnotes” or “Endnotes”.
Select the location of
footnote or endnote from
down arrow list.
In the format section, select
the types of “Number
format”, “Start at” or
“Numbering” .
205
Click the “Insert”.

Using styles list
Highlight the text you want
to use to create a style.
2. Apply various formats to the
text e.g. bold, italic,
underline etc.
3. Click the Styles box in the
formatting toolbar and type
a name for the style.
4. Press “Enter” key to apply
the style name.
NB; you can apply an existing
206
style.
1.
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Generating a table of contents and index
1.

2.
3.
4.

5.
6.
7.

Turn to the page you
want to insert the table
of contents.
On the “Insert” menu.
Point to “Reference”
Click “Index and Tables”
(Index and Tables dialog
box is displayed).
Click the “Table of
Contents” tab.
Set the table of contents.
Click “OK” button.
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Creating tables


A table is a feature in MS-Word made of
rows and columns that is used to organise
and enhance display and information.
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Steps of “Table” function
1.
2.
3.

4.

5.

On the “Table” menu
Point to “Insert”
Click the “Table”
(Insert table dialog
box is displayed)
In the “Table size”
section, select the
number of columns
and rows from arrow
key.
Click the “OK” button
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Steps of “create a table using the drawing tool”
1.
2.

3.
4.

On the “Table” menu.
Click “Draw table” (the
mouse pointer changes
to a pencil symbol and
Tables and Borders
toolbar is displayed).
Drag the pointer to draw
the outline of the table.
Fill in the table with rows
and columns by
dragging the pointer as
you would draw using an
ordinary pencil.
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Uses/functions of tables
1.

Used to organise and present
information.

2.

Used to align numbers for calculation
purposes.

3.

Can be used to create different forms
such as invoice, calendar etc.
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Editing a table
1.

2.
3.

4.

Inserting rows/columns.
Deleting rows/columns.
Merging cells – refer to combining of
more than one cell in a table.
Splitting cells – refers to subdividing a
cell into more cells.

212

106

Steps of insert “rows” in a table
1.

Place the cursor where
you want to insert a row.

2.

On the “Table” menu.

3.

Point to “Insert”.

4.

Click the “Row above”
or “Row below”
213

Steps of insert “Columns” in a table
1.

2.
3.
4.

Place the cursor
where you want to
insert a column.
On the “Table” menu.
Point to “Insert”.
Click the “Column to
the left” or “Column
to the right”.
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Steps of “delete rows, column or cells”
1.

Select the rows,
columns or cells to
be deleted.

2.

On the “Table” menu.

3.

Point to “Delete”.

4.

Click “Columns”,
“Rows” or “Cells”.
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Steps of “Merging cells” in a table
1.

Select cells to be
merged.

2.

On the “Table” menu.

3.

Click the “Marge
cells.
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Steps of “Splitting cells” in a table
1.
2.

3.

4.

5.

Select sells to be
split
On the “Table” menu
Click the “Split cells”
(Split Cells dialog
box is displayed)
Select number of
columns and rows
from arrow key
Click the “OK” button
217

Formatting a table


MS-Word provides facilities that let user
format table border styles and shading.
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Steps of “Formatting table” function
1.
2.

3.

4.

5.

On the “Table” menu
Click the “Table
AutoFormat” (Table
AutoFormat dialog box is
displayed)
Select the type of
category from drop down
list of “Category”
Select the table style
from drop down list of
“Table style”
Click the “Apply” button
219

Table conversions


This feature allows the user to convert
table to the text and text to table.
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Steps of “Convert a table to text”
1.

2.

3.
4.

5.

6.

Select the entire table or
row and columns you
want to convert to text
On the “Table” menu
Point to “Convert”
Click the “Table to Text”
(Convert Table To Text
dialog box is displayed)
Enter or select the
character to be used as
a separator
Click the “OK” button
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Steps of “Convert text to table”
1.
2.
3.
4.

5.

6.

Highlighting text you
want to convert to table.
On the “Table” menu
Point to “Convert”
Click the “Text to table”
(Convert Table To Text
dialog box is displayed)
Enter or select the
character to be used as
a separator
Click the OK button222
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Performing arithmetic calculation in a table


It’s possible to perform mathematics calculations such as
sum, products etc, if a table has numeric figures. To
calculate numerical values in a table, we use cell
references. A cell is a cross-section of row and column.
Columns are represented by letters A, B, C, …. while
rows are represented by 1, 2, 3 …. as shown in table
below figure.

A1

B1

C1

D1

E1

F1

G1

H1

I1

J1

A2

B2

C2

D2

E2

F2

G2

H2

I2

J2

A3

B3

C3

D3

E3

F3

G3

H3

I3

J3

A4

B4

C4

D4

E4

F4

G4

H4

I4

J4

A5

B5

C5

D5

E5

F5

G5

H5

I5

J5
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Steps of use “Calculation” functions
1.

2.
3.

4.

5.

Click in the cell the
result to be displayed
Click the “Table” menu
Click the “Formula”
(Formula dialog box is
displayed)
Type a formula e.g.
=SUM(A1:E1) in the box
of “Formula”
Click the “OK” button
224
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Sorting text


In MS-Word you can sort a list of text,
numbers and dates in ascending or
descending order.
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Steps of “Sorting text”
1.

2.
3.

4.

5.

6.

Highlight the text list or
table you want to sort.
On the “Table” menu.
Click the “Sort” (Sort Text
dialog box is displayed).
In the “Sort by” section,
select the type of data from
down arrow list i.e. “Text”,
“Number” or “Data”.
Select “Ascending” or
“Descending”.
Click the “OK” button. 226
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Mail merge documents


Mail merge is the process of generating
personalised letters or documents by
combining a main document e.g. a letter
with an existing data source such as the
contact book.
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Steps of setting a “Mail Merge” 1
1.

2.
3.
4.

Open or create a main
document such as form
letter. Main document
contains the information
you want to distribute.
On the “Tool” menu.
Point to “Letters and
Mailings,
Click the Mail Merge. (Mail
Merge task pane is
displayed). The pane
presents the user with a
step by step wizard that
guides takes you through
228
the process.
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Steps of setting a “Mail Merge” 2
Select document type. In this
case select the “Letters”
6. Click the “Next” arrow at the
bottom of the task pane.
7. Select starting document. In
this case select the “Use the
current document”.
8. Click the “Next” arrow.
9. Select recipients. In this
case select the (Type a new
list).
10. Click the “Next” arrow (New
Address List dialog box is
displayed).
5.
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Steps of setting a “Mail merge” 3
11.

12.
13.

14.

15.

Click the “Customize”
button (Customize Address
List dialog box is displayed)
Customize address list (add,
remove or rename fields).
After you finish to
customize, click the “OK”
button (Customize Address
List dialog box is closed).
Click the “Close” button
(Save Address List dialog
box is displayed).
Save the data source. 230
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Steps of setting a “Mail merge” 4
16.

17.

18.
19.
20.

After you save the data
source, “Mail Merge
Recipients” dialog box is
displayed. Click the “OK”
button of this dialog box.
A Mail Merge toolbar is
added onto the data source.
Move the mouse pointer to
get the tool tip for each
button as shown left above
figure.
Edit data source to type
recipients data.
Click the “Next” arrow.
Click the “More items”
(Insert Merge Field dialog
231
box is displayed).

Steps of setting a “Mail Merge” 5
21.

22.

23.

Insert each field as
desired.
After you finish to insert
each field, click the
“Close” button.
Click the “Next” arrow
two times.

You are now ready to
merge.

232

116

Preview merged documents


Before you print click
the “Preview” button in
order to be sure that
everything is in the
right place. To send a
merged document to a
printer, click the “Print”
button on the mail
merge toolbar. A
dialog box similar left
figure is displayed.
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Send merged documents via e-mail


Click the “Merge” button on
the Mail Merge toolbar to
see dialog box of left figure.
Select “E-mail” or “Fax” in
the merge to box. Click the
“Setup” button to specify
the e-mail addresses or
faxing number then click
the merge button. The
internet connection wizard
starts and if your computer
is properly configured, the
mail merged document will
be sent.
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Files in mail merge
1.

2.

3.

The primary file (Main document) – this
file contains data that will appear in all
documents.
Data source (secondary file) – this file
contains variable information e.g. names,
address, telephone etc.
Merged file – once you finish inserting
merge fields from the data source in the
main document. You can merge.
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Inserting graphics


Inserting graphics – refers top non-text
image generated by a computer.
Graphics can be photographs, drawings,
pictures, charts and graphs. In MS-Word
graphical objects are inserted from
(source). Clip gallery, scanner, drawing
tools, charts, from another file.
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Steps of “Insert a graphics from clip art gallery”
1.

2.

3.
4.
5.
6.
7.

Position the insertion pointer
where you want your object
to be inserted.
On the “Insert” menu
Point to “Picture”
Click the “Clip Art” (Clip Art
task pane is displayed)
Type the category name in
the “Search for” box
Click the “Go” button (Some
graphics are displayed)
Select a graphics and click
the “Insert” of drop down
237
menu.

Steps of “Insert an image from a scanner”
1.

2.
3.
4.
5.

6.

Position the insertion pointer
where you want your picture
to appear
On the “Insert” menu
Point to “Picture”
Click the “From Scanner or
Camera”
To scan, follows the
instructions that come with
your scanner
When the image appears on
the screen you can edit
format it as required, the
same way you would with a
238
clipart.
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Steps of “Inserting a picture from another file.
1.

2.

3.
4.

5.

6.
7.

Position the insertion
pointer where you want
your picture placed.
On “Insert” menu.
Point to “Picture”.
Click “From File” (Insert
Picture dialog box is
displayed).
Locate the file that contain
the image you want to
insert e.g. My Picture.
Select the object you want
to insert.
Click the “Insert” button.
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Steps of “Insert graphics from Drawing Tools”
1.
2.
3.

4.

On the “View” menu.
Point to “Toolbars”.
Click the “Drawing”
(Drawing toolbar is
displayed).
Draw a line, a circle,
an arrow or a
rectangle using this
toolbar
240
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Steps of “Insert graphics from Autoshapes”
1.

2.

3.
4.

Click the “Autoshapes”
button on the drawing
toolbar (drop down menu
is displayed).
Point to category
required.
Select a type of object.
Place the pointer where
you want to draw that
shape and drag to the
required size.
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Steps of “Insert a chart”
1.

2.
3.
4.

5.
6.

Position the insertion
pointer where you want
your object to be
inserted.
On the “Insert” menu
Point to “Picture”
Click the “Chart”
(Datasheet is displayed)
Edit the “Datasheet”
Click the “X” button 242
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To format or edit a picture



MS-Word provides the user with a picture editing toolbar that
lets you adjust the brightness, contrast, change it to black
and white or grayscale and crop the image. Cropping refers
to hiding the unwanted details so that they do not come out
when printing. To display toolbar, click on View menu, point
to toolbars then select Picture. The picture toolbar has
buttons that enable a person to format a picture as shown in
243
above figure.

Steps of “resize or move a drawing”
1.

2.

3.

Click anywhere
inside it, the place
holder appear.
To move it, hold
down the mouse
button and drag.
To resize it, place
the pointer at one of
the place holders
and drag.
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Steps of “fill the object with colour”
1.

2.
3.

4.

Double click the
object (Format
AutoShape dialog
box is displayed).
Select the “Colors
and Lines” tab.
In the Fill section,
select the colour you
want to fill from drop
down list of Color.
Click the “OK” button.
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Steps of “fill effects”
1.

2.
3.

4.
5.
6.

Double click the object
(Format AutoShape dialog
box is displayed).
Select the “Colors and
Lines” tab.
In the Fill section, click the
“Fill Effect” from drop down
list of Color (Fill Effect
dialog box is displayed).
Select the appropriate fill
effect.
Click “OK” button of Fill
Effect dialog box.
Click “OK” button of Format
AutoShape dialog box..246
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Inserting symbol


A symbol is a special character that is not
included on the standard keyboard. For
example, Ø and ù are symbols that are not
available on the standard keyboard.
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Steps of insert a “Symbol”
1.

2.
3.

4.

5.

6.

Move the text cursor to
the position where the
new symbol will be
inserted.
On the “Insert” menu.
Click the “Symbol”
(Symbol dialog box is
displayed).
Select a symbol you
want to insert from list.
Click the “Insert” button.
248
Click the “Close” button.
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Printing


The choice of printer depends on the
quality of hardcopy desired. Before
printing it’s important that you preview
your document. To confirm that no details
are outside the printable area. To ensure
that the document layout is okay.
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Steps of “Print” function
1.
2.

3.

4.

On the “File” menu
Click the “Print” (Print
dialog box is displayed)
Select printer, page
range and number of
copies.
Click the “OK” button

NB; shortcut key
Ctrl + P
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Review questions 1
1.
2.
3.
4.
5.
6.
7.
8.

What is a word processor?
State the purpose of word processor.
Name four functions performed by a word
processor.
What is a document draft?
State four advantages and two disadvantages
of using a word processor over the typewriter.
What is document formatting?
Explain the difference between type over and
insert mode in word processing.
Define the term word wrap.
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Answer of review questions 1-1
1.
2.

3.
4.
5.

A computer program that enables a person to create, save,
retrieve, edit, format and print text based documents.
Writing letters, projects, reports, essays and books etc.
Creating, printing, saving, editing, formatting documents.
One that is the initial copy for proofreading.
Advantages;
A)
A document can be stored for further use.
B)
Typing is easier and efficient.
C)
Word processors have superior document formatting features.
D)
It is possible to print multiple copies at once.
Disadvantages;
A)
Computers are more expensive.
B)
Computers use electricity hence not appropriate where there is
no electric power.
252
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Answer of review questions 1-2
6.
7.

8.

Making a document attractive by bolding,
italicising, bordering, colouring, etc.
Type over – deletes current text at cursor
position and inserts new text.
Insert mode – pushes old text away as
new text is inserted at cursor position.
Automatically moving a word to the
beginning of a new line if it cannot fit at
the end of the previous line without
pressing outer key.
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Review questions 2
1.

2.
3.
4.
5.
6.
7.

State two examples of word processing
programs.
What is a toolbar?
Explain how you can protect a document from
unauthorised opening or altering.
What is meant by the terms creating and
editing a document?
How can you save a document to a different
word processor format?
Define the tem scrolling.
Explain the importance of the status bar.
254
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Answer of review questions 2
1.
2.

3.
4.

5.

6.
7.

Microsoft Word, Wordstar, Lotus Wordpro,
Wordperfect.
A group of shortcut command icons arranged on a
single graphical structure.
Use passwords to prevent opening or editing.
Creating – typing text in a new document screen.
Editing – making changes to an already existing
document.
Click file then Save as command. In the save as dialog
box, select a format type in the File of type box. Click
Save button to save.
Moving of on screen pages up, down, left and right.
Help the user to interact with the application because it
displays the processing status of the application.
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Review questions 3-1
1.
2.

3.
4.
5.

6.
7.
8.

Explain the meaning of the term blocking text?
What is the difference between copying and moving text?
When is the find and replace command used?
What is a wildcard? How can it be used to search for a
word that starts with the letter “O” in a document.
What is the difference between just searching for a
particular word in a document and searching for a word
that is whole?
Explain the importance of proofreading a document.
Give two methods of proofreading a prepared document.
Give the two types of dictionaries that are used by a spell
checker program. Which one is likely to have non-English
words and why?
256
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Review questions 3-2
9.
10.
11.

12.
13.
14.

15.

Name any five parts of the Microsoft Word application
window.
Give any five document formatting.
Give any five document formatting feature.
What is a thesaurus?
Distinguish between the autocomplete and the
autocorrect feature in word processing.
Hassan has a problem when typing; every time he
wishes to type the word Good, he mistakenly types
God. What can he do to continue typing without
worrying about having to go back to correct the same
word over and over again?
Explain the use of undo and redo commands.
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Answer of review questions 3-1
1.
2.
3.
4.

5.

6.
7.

Selecting several lines of text in order to work with them as a
whole.
Copying – making a duplicate copy of text. Moving – relocating
text from one place in a document to another.
To search for words that you want substituted by others.
A special character e.g. * or? Used to represent a set of words
that have some similar characteristics. Type 0 followed by asterisk
(*).
Searching for a word will find the word even when it is part of
other words e.g. searching for spell will also find Spelling and
Spellchecker. However, if you search for a whole word, only the
whole independent text will be found, e.g. only Spell and no other
will be found.
Eliminate mistakes to improve a document readability.
Spelling and grammar checker, Thesaurus, and
Autocomplete/Autotext/autocorrect.
258
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Answer of review questions 3-2
8.
9.
10.

11.
12.
13.

14.
15.

Standard dictionary and custom dictionary.
custom dictionary – words can be added.
Title bar, Menu bar, Editing screen, Rulers, Toolbars and status
bar.
Enhancing a document’s appearance by bolding, italicising, etc.
Bolding, Font colouring, Text alignment, Font type, Setting tabs,
Underlining, Italicising and Font size.
Thesaurus provides synonyms or words that have same meaning
as the one selected.
Autocomplete – helps a person to type quickly by completing a
word that has already started to be typed by the user
automatically. Autocorrect – automatically replaces mistyped
words with the correct ones as set by the use.
Set the autocorrect feature to automatically detect and replace the
word God with Good.
Undo – reverses the latest action. Redo – does the undone action.
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Review questions 4
1.

2.
3.

Give at least four examples of fonts available in
Microsoft Word.
Outline the procedure for inserting:
Page numbers;
A)
B)
C)

4.
5.
6.

Footnotes and endnotes;
Headers and footers;
What is a tab? Why are tab stops important in a
document?

Explain the importance of drop cap in a document.
What is line spacing? Give any two line spacing
specifications.
Give and explain four text alignment features. 260
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Answer of review questions 4
1.
2.

3.

4.
5.
6.

Times New Roman, Arial, Bookman Old Style, Comic Sans MS,
etc.
A). Click Insert menu, Page numbers.
B). Click Insert menu, Reference.
C). Click View menu, Header and Footer.
A tab spacing is a short distance moved by the text cursor
when the tab key on the keyboard is pressed. It is used to align
text on the page.
Drop cap emphasises a particular starting word in a paragraph.
The distance between two text lines in a document. Examples
include single space, double space, etc.
Left alignment, Center alignment, Right alignment and Justified.
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Review questions 5
1.
2.
3.

4.
5.
6.

7.
8.

9.

Differentiate between drawing and inserting a table in a document.
Define the term cell in reference to tables.
Give a reason why in may be necessary to merge cells in a table.
Define the term sorting.
Explain how you can convert some typed text into a table using
Microsoft Word.
What would happen to the cursor in a table when the following actions.
A) Pressing the tab key.
B) Pressing the shift+tab key.
C) Pressing the enter key.
Define the term function as used in table calculations.
Define each of the following:
A) A form letter.
B) A data source.
C) Mail merge.
262
List four ways of merging a document with its data source

131

Answer of review questions 5
1.
2.
3.

4.
5.
6.

7.
8.

9.

Drawing – use the pen tool to draw the table. Inserting table – use the Table
menu-Insert-Table command.
Cell – section between a row and a column.
To create larger cells in a table without increasing the height or width of
existing cells.
Arranging text in ascending or descending order.
Highlight the text then click Table-Convert text to table.
A). Moves text cursor one column to the right in the same row.
B). Moves text cursor one column to the left in the same row.
C). Increases cell height.
Mathematical formula that accomplish calculations in a table.
A). Common letter (main document) that is to be personalised.
B). A file of data records of the people that will receive the form letter.
C). Combining the data source with the form letter or main document.
Merge to fax, Merge to printer, Merge to e-mail and Merge to new document.
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Revision questions
1.
2.

3.
4.
5.

6.
7.
8.
9.

Define the term graphic and give one example.
Explain how to achieve the following
A) To move a graphic from one place on the page to another.
B) To change the brightness of a graphic.
List three sources of graphics that can be used in Microsoft Word.
What is an autoshape?
How can you do the following
A) Change the thickness of an autoshape outline;
B) Fill an autoshape with colour;
C) Enter text in an autoshape.
What is the difference between object linking and embedding?
Describe how you would increase the size of a clip art that is
embedded in a document.
Give any three sources of images or objects in a word processor.
Explain the concept of importing objects into a word processor.
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Answer of revision questions
A graphic is a non-text object like a picture, drawing, etc. e.g. clipart.
A). Click it to select then drag.
B). Click it then click the increase brightness button on picture toolbar.
From scanner, from file and clipart.
A graphic image that is predefined in shape but the user draws it by
selecting it then dragging its size on the screen.
A). Select it then choose a different line thickness on the drawing toolbar.
B). Select it then choose a fill pattern from the fill bucket on toolbar.
C). Right click the autoshape then select the Enter text command. Type the
text then click a blank area on the screen to apply.
Linking – object imported can only be edited in the original application from
which it was created. Embedding – object imported becomes part of the
current application and can be edited there.
Click it to select it, then drag handles to increase size.
Import from file, from clip gallery and by drawing.
This refers to inserting a picture or clipart from a different application storage
265
or Internet.

1.
2.
3.
4.
5.

6.

7.
8.
9.

Practical activity 1


Jitegemee Self Help Group is a society of young
entrepreneurs. The Group is in the process of writing a
proposal in order to get funding from one of the NGOs and
the government. The secretary of the Group, Mr. Kagezi has
requested you to type for him a five page handwritten
proposal.
Use the following to create the document outline;







Introduction
Executing summary
Future outlook and trends
Office equipment and personnel
Operational plan
Conclusion

Save it as Jitegemee Plan.
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Practical activity 2


Open the an existing document of not
less than ten pages perform the following
operations;
a)
b)
c)

Change Title font to Tahoma, bold, 18 points
size and centre it on the page, underline.
Drop the first character of the first paragraph
to occupy three lines below it.
Insert page numbers at the bottom right and
footers at the centre of page.
267

Practical activity 3
1.

Figure right shows a
drawing done using Word
processing software;
a)

b)
c)

2.

Draw the object and
make the outer circle to
have double lines outline.
Fill the inner circle with
red colour.
Fill the triangle with blue
colour and make it to lie
behind the inner circle.

Print two copies of
selected page of
Jitegemee Plan.
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Chapter 4
Spreadsheet
Njabini Boys high school
Form two work
269

Introduction


Spreadsheet is essentially a ledger sheets
that enables the user enter, edit and
manipulate numeric data.
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Types of spreadsheets
Manual spreadsheet – this spreadsheet
consists of a book like ledger with many
sheets of papers divided into rows and
columns on which data elements are
entered manually using a pen or pencil.
 Electronic spreadsheet – this spreadsheet
is prepared using a computer program that
enables the user to enter values in rows
and columns and manipulate them
mathematically using formulae.
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Advantages of electronic spreadsheet









Entries made using spreadsheet are faster and
accurate.
It offers a large area for data entry and manipulation.
Electronic spreadsheet produces neat and
presentable output.
It has better documentation formatting capabilities.
It has inbuilt formulae called functions that enables
the user to quickly manipulate mathematical data.
Has ability to perform automatic recalculation.
It utilizes large storage space on computer storage
devices to save and retrieve documents.
272
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Examples of spreadsheets programs


Viscal



Lotus 1-2-3



Microsoft Excel



VP – Planner
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Components of spreadsheet
(Worksheet and Database)




Worksheet – this is the
component in which data
values are entered. It’s
made up to of rows and
columns.
Database – the data
management feature of
spreadsheet can be
found on the data menu.
Data entered in
spreadsheet can be
manipulated by sorting,
filtering, calculating
subtotals etc.
274
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Components of worksheet
(Graphs)


Graphs – a graph is a
pictorial
representation of the
base data on a
worksheet.
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Examples of graphs found in MS-Excel


Pie chart



Graphs e.g. bar,
column



Line graphs etc.
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Application areas of spreadsheet 1






Accounting – many accountants and business
people find spreadsheet a useful tool to use in
recording daily transactions and keeping of financial
records. Spreadsheet comes with inbuilt functions
that make accounting tasks easier.
Data management – spreadsheet enables neat
arrangement of data into tabular structure. Data
management functions include sorting, filtering,
using forms to enter and view records.
Statistical analysis – spreadsheets have in-built
statistical analysis tools that can speed up data
manipulation. Some of statistical functions found in
MS-Excel are: Average, Maximum, Median,
Minimum, Mode, Sum etc.
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Application areas of spreadsheet 2






Forecasting (“What if analysis”) – this feature
involves changing the value of one of the
arguments in a formula to see the difference
the change would make on the result of the
calculation.
Scientific application – engineers, scientific and
technical users store empirical data, perform
statistical analysis, build and prepare complex
mathematical models using spreadsheet.
Home/personal use – this involves tracking
cash flow, preparing household budgets and
personal financial statements.
278
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Starting Microsoft Excel
1.

2.

3.

4.

Click on the “Start”
menu.
Point to
“Programs/All
Programs”.
Point to “Microsoft
Office 2003”.
Click “Microsoft
Office Excel 2003”.
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Parts of MS-Excel windows
1.
2.
3.
4.
5.
6.
7.
8.
9.
10.
11.
12.
13.
14.

Title bar
Menu bar
Standard toolbar
Formatting toolbar
Name box (Cell address)
Formula bar
Column header
Row header
Vertical scroll bar
Horizontal scroll bar
Worksheet tab
Cell pointer
Status bar
280
Worksheet
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Microsoft Excel application window 1
Title bar – it displays the title of the application and control
buttons for minimising, maximise and closing application.
Menu bar – displays a list of menu options e.g. inserts, view,
edit etc.
Standard tool bars – has shortcuts to some of the most
commonly used menu commands e.g. copy, cut etc.
Standard tool bar – has also shortcuts to some of the most
commonly used menu commands e.g. bold, italic etc.
Name box (Cell address) – is the combination of a column
header and a row header the indicate of a specific cell.
Formula bar – it enables the user to enter or edit a formula or
data in a cell.
Column header – indicates vertical direction of the cell. It is
located above the worksheet and lined up in order to the281
alphabet.

1.
2.

3.
4.
5.
6.
7.

Microsoft Excel application window 2
8.
9.
10.
11.
12.
13.
14.
15.

Row header – indicates horizontal direction of the cell. It is
located left the worksheet and lined up in order to the figure.
Vertical scroll bar – the user drags to scroll upward or
downwards of a worksheet.
Horizontal scroll bar – the user drags to scroll right or left of a
worksheet.
Worksheet tab – shows the number of worksheets in the
workbook.
Cell pointer – it marks the position of the current cell or the
insertion point.
Status bar – displays information about the program currently
running.
Worksheet – consists of cell, rows and columns where data is
entered.
282
Workbook – it consists of several worksheets.
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Other parts of MS-Excel






Cells – a cell is an intersection between a row
and a column. A column is a vertical
arrangement of cells labelled A,B,C… while a
row is the horizontal arrangement labelled
1,2,3…
Active cell pointer – a cell pointer indicates the
current active cell. It is highlighted with a dark
outline.
Cell address – the cell address id the
combination of a column header and a row
header that indicate the location of a specific cell
such as A1, B2, C3 etc.
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Navigation the MS-Excel screen 1
1.

2.

Click cell D5. notice that
the cell pointer
immediately moves to he
cell and the name box
reads D5. typing on the
keyboard now inserts
entries in cell D5 as long
as the pointer is still there.
Click letter A that heads
the first column. Notice
that the whole column is
highlighted.
284
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Navigation the MS-Excel screen 2
3.

Double click cell E10.
Notice that the insertion
pointer blinks in the cell
and you can start typing
characters inside the
cell.

4.

Click the down arrow on
the vertical scroll bar.
The worksheet moves
upwards on the screen.
The opposite happens
when you click the left
arrow on the vertical
scroll bar.
285

Navigation the MS-Excel screen 3
5.

6.

Click the right button on the
horizontal scroll bar. The
worksheet moves on the
left. The opposite happens
when you click the left
button on the horizontal
scroll bar.
Press the “right arrow” key
on the keyboard. Notice
that the cell pointer moves
one column to the right on
the same row. This can
also be done by pressing
the “Tab” key once. 286
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Navigation the MS-Excel screen 4
7.

8.

Press the “left arrow” key
on the keyboard. Notice
that the cell pointer
moves one column to
the left on the same row.
Pressing “Shift+Tab”
gives the same results.
Press the “up arrow” key
on the keyboard. Notice
that the cell pointer
moves one row up on
the same column.
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Navigation the MS-Excel screen 5
9.

10.

11.

Press the “down arrow” key
on the keyboard. Notice that
the cell pointer moves one
row down on the same
column.
Press the “End” key. The
status bar will display the
message “END”. If you press
the right arrow key, the cell
pointer will moves right to the
last cell on the row. If the left,
up or down keys were to be
pressed instead, the cell
pointer would move to the
last cell to the left, top or
bottom respectively.
Pressing “Ctrl+Home” moves
the cell pointer to the first cell
288
of the worksheet i.e. cell A1.
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Steps of “Using blank template”
1.
2.

3.

On the “File” menu,
Click “New” (New
workbook task pane is
displayed).
In the “New” section,
click “Blank
workbook”. (New
workbook is opened).

NB; shortcut key
Ctrl + N
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Steps of “Using a template”
1.
2.
3.

4.

5.

6.

On the “File” menu.
Click “New” (New Workbook
task pane is displayed).
On the task pane under
“Templates”, click “On my
computer” (Template dialog
box is displayed).
In the templates dialog box,
click “Spreadsheet Solution”
tab.
On the spreadsheets
solutions tab, click the
template that you wish to
create.
Click the “OK” button. 290
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Components of a worksheet
1.

2.

3.

4.

Cells – an intersection
between a row and
column.
Row – horizontal
arrangement of cells.
Columns – vertical
arrangement of cells.
Range – a group of
rectangular cells that
can be selected and
manipulated as a block.
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Entering data into a worksheet


As you type an entry,
it is displayed in the
formula bar. To place
the content into the
active cell press
“Enter” key, an arrow
key or click into
another cell.

292

146

Cell data types


There are four basic types of data used in
spreadsheet.
 Labels
 Values
 Formulae
 Functions

293

Labels


Any text or
alphanumeric
characters entered in a
cell are viewed as
labels in a spreadsheet
program. Labels can
be row and column
headings used to
describe the contents
of row or column e.g.
class, name, sex etc.294
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Values


They are numbers
that can be
manipulated
mathematically e.g.
currency, data,
numbers (0-9) etc.
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Formulae


They are user
designed mathematical
expressions that create
a relationship between
cells and return a value
in a chosen cell.

NB; formula must start
with an = sign.
296
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Functions


They are in-built
predefined formulae
that the user can
quickly use instead of
having to create a
new one each time a
calculation is to be
done e.g. SUM,
COUNTIF, IF etc.
297

Steps of saving a workbook
1.
2.
3.

4.

5.

On the “File” menu
Click “Save as” (Save as
dialog box is displayed).
Select the location in which
your workbook will be
saved in the “Save in” box
Type a unique name for the
workbook in the “File name”
box.
Click the “Save” button.

NB; shortcut key
F12
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Retrieving a workbook
1.
2.
3.
4.

5.

On the “File” menu, (or
standard toolbar)
Click “Open”.
Click the “Look in” drop
down list arrow.
Select the drive or folder
where the workbook
was saved.
Double click the
workbook icon that you
want and the worksheet.

NB; shortcut key
Ctrl + O
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Closing a workbook.
1.

On the “File” menu.

2.

Click “Close”



This closes the current
workbook but does not
close the application.

NB; shortcut key
Ctrl + F4
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Exiting a workbook
1.

On the “File” menu.

2.

Click “Exit”.

NB; shortcut key
Alt + F4
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Block operations


Performing calculations on a worksheet
data involves block operations. A block of
selected cells in a worksheet is referred to
as a range. A range is specified by the
address of its top left and bottom right
cells or using a name.
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Steps of “select a range of continuous cells”
1.

Click the top left cell
of the range to be
selected.

2.

Hold down the
“Shift” key.

3.

Click the bottom
right cell of the
range (the range will
be highlighted)
303

Steps of “select a range of non-continuous cells
1.

2.
3.

Click the top left cell
of the range to be
selected.
Hold down the “Ctrl”
key.
Click the bottom
right cell of the
range. “Ctrl selects
individually clicked
rows, columns or
cells.
304
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Steps of create named range proceed as follows
1.

Select the range to
be named.

2.

Click inside the
name box. Delete
the cell reference
and type a name for
the range.

3.

Press “Enter” key to
apply.
305

Arithmetic operators
Description
/ Division

Example
=A2/B2

* Multiplication =A2*B2
+ Addition

=A2+B2

- Subtraction

=B2-A2



Arithmetic operators mostly
follow the rule similar to
mathematical concept of
BODMAS. This means that
whatever is in parenthesis is
evaluated first. Multiplication
and division are evaluated
from left to right while
addition and subtraction are
evaluated last. Left table
shows a summary of
operators used to create
306
formulae.
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Relational operators
Description

Example

=

Equal to

=A2=B2

>

Greater than

=A2>B2

<

Less than

=A2<B2

<> Not equal to

=B2<>A2

<= Less than or
equal to
>= Greater than
or equal to

=A2<=B2



A relational operator
returns either true or
false depending on
the magnitude of the
value being evaluated.
Table right is
summary of a
relational operator.

=A2>=B2
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Operator precedence


If several operators are used
in a single formula, MS-Excel
performs the operations in
the order shown in table right.
A formula with operators that
have same precedence i.e. if
a formula contains both
multiplication and division,
operators are evaluated from
left to right. Enclosing part of
the formula to be calculated
in parentheses or brackets
makes that part to be
calculated first.
308
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Autofill


You can quickly fill adjacent cells with data
that continues a formula or a series of
numbers, days, dates or etc automatically
by dragging the fill handle.
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Steps of “Autofill”
1.

2.

3.

Select the cell which is
containing a formula or
word or figure.
Place the mouse pointer
bottom right corner of
the selected cell, then
pointer sign will be
changed to black cross.
Move the black cross
pointer up to where you
want to make a copy
using drag and drop.
(down, up, left or right).
310
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Cell references


A cell reference identifies a cell or a range of
cells on the worksheet and shows Microsoft
Excel where to look for the values or data
needed to use in formulas. MS-Excel uses the
A1 cell reference style that identifies a cell by
its column label followed by row number e.g.
B1, E10 etc. RICI reference style can also be
used where a cell is referenced by its row
number followed by its column number e.g. R3,
C4, R5, C20 etc.
311

Relative reference


This is a cell reference
whose cell references
keep on changing
automatically depending
on their position in the
worksheet e.g. if you
type formula
=B2+C2
in cell D2 if the formula
is copied to cell D3 it
automatically changes to
=B3+ C3.
312
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Absolute referencing


This is used when you
copy a formula to
different cell and you
don’t want Excel to
adjust references. To
make a formula
absolute, add a dollar
sign before the parts of
cell reference that do
not change
313
e.g. =A5×$B$2.

Mixed cell referencing


This is a combination of relative and absolute
reference
e.g. $A3 or A$3
in the first case the column reference is absolute
while the row is relative, in the second case the
column reference is relative while the row
reference is absolute.

314

157

Using in-built functions


A function must start with an (=) sign followed
the function name and arguments. Argument are
numeric, logical values or text enclosed in
parenthesis. For example, in =SUM(A3:F3),
SUM is the function that adds the range A3 to F3
which is the argument. In MS-Excel, functions
are categorized according to the nature of
problems they work on. We shall look at the
following categories of in-built functions;
 Mathematical
 Statistical
 Logical
 Date

and time
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Steps of “using in-built functions”
1.
2.

3.
4.

5.

On the “Insert” menu.
Click “function”
(“Insert Function”
dialog box is
displayed).
Select the category.
In the function list
box, select a
function
Specify the function316
argument then click

158

Basic functions and formulae


A formula is a sequence of values, cell
references, names, functions or operators
in a cell that together produce a new value
while a function is an in-built formula for
solving standard problems.
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Mathematical functions (SUM)


Add all the value in the selected in the
range of cells. For example if A3, B3 and
C3 contains 20, 50 and 80 respectively,
=SUM(A3:C3)
returns 150.
318
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Steps of “SUM” function
1.

2.

3.

4.

Select the cell where you
want to return the sum
value.
Click the “Autosum”
command on the standard
toolbar. (formula is
displayed in the cell which
you selected).
Select the range for add the
numbers in a range of cell
using drag and drop. (data
range is displayed in the
brackets).
Type “Enter” key.
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Mathematical functions (ROUND)


Rounds a number to a specified number of decimal
places. Zero round off the number to the nearest integer.
For example
=ROUND(49.769,1)
returns 49.8.
while
=ROUND(49.769,0)

returns 50.
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Steps of “ROUND” function
1.
2.
3.
4.

5.
6.
7.
8.

9.

10.

Select the cell where you want to
return the round figure.
On the “Insert” menu
Click “Function”.
Type “ROUND” in the search box.
Click “GO” button.
Select a function from the
recommend list.
Click “OK” button.
Click the cell which is the number
you want to round. (cell address
is displayed in the “Number” box).
Type the number of decimal
which you want to round in the
“Num_digits” box.
Click “OK” button.
321

Mathematical functions (SUMIF)


Conditionally add the specified cells
according to the set criteria.
=SUMIF(A3:A10,”>=1000”)
returns a value if, and only if, the sum is
greater than or equal to 1000.
322
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Steps of “SUMIF” functions
1.
2.
3.
4.
5.
6.
7.

8.

Select the cell where you want to
return the sumif value.
Click “fx” command on the
formula bar.
Select “Math & Trig” category
from the down arrow list.
Select a function “SUMIF” from
the list.
Click “OK” button.
Select the range you want to
evaluate using drag and drop.
Type the criteria which is the
condition or criteria in the form of
a number, expression or text that
defines which cells will be added.
Click “OK” button.
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Mathematical functions (PRODUCT)


Multiplies all the values in the arguments.
For example,
=PRODUCT(40,3,2)
returns 240.
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Steps of “PRODUCT” function
1.
2.
3.
4.

5.
6.
7.
8.

9.

10.

Select the cell where you want to
return the product value.
On the “Insert” menu.
Click “Function” .
Type “Product” in the search box.
Click “GO” button.
Select “PRODUCT” from the
select a function list.
Click “OK” button.
Select the range in the “Number1”
box where you want to multiply
using drag and drop.
If you want to multiply other range,
insert that range in the “Number 2”
box using drag and drop.
Click “OK” button.
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Statistical functions (AVERAGE)


It returns the average (mean) of a set of
values which can be numbers, arrays or
references that contain numbers e.g. value
20 is in cell B2 and 10 in cell C2 then
= AVERAGE(B2:C2)
returns 15 as the average.
326
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Steps of “AVERAGE” function
1.

2.

3.

4.

5.

Select the cell where you
want to return the average
figure.
Click the down arrow of
“Autosum” command on the
standard toolbar.
Click the “Average” (formula
is displayed in the cell which
you selected).
Select the range for
calculate average using
drag and drop. (data range
is displayed in the brackets).
Type “Enter” key.
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Statistical functions (COUNT)


Counts the number of cells that contain
values within a range
=COUNT(B2:E7)
returns 4 if all cells have values.
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Steps of “COUNT” function
1.

2.

3.

4.

5.

Select the cell where you
want to return the count
figure.
Click the down arrow of
“Autosum” command on the
standard toolbar.
Click the “Count” (formula
is displayed in the cell
which you selected).
Select the range for count
using drag and drop. (data
range is displayed in the
brackets).
Type “Enter” key.
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Statistical function (COUNTIF)


Conditionally counts the number of cells
within a range that meets a given condition.
For example, if A3, B3, C3, D3 and E3
contain 20, 50, 80, 60 and 45 respectively
then
=COUNTIF(A3:E3,”>50”)
returns 2.
330
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Steps of “COUNTIF” functions
1.
2.
3.
4.
5.
6.
7.

8.

9.

Select the cell where you want to
return the countif figure.
On the “Insert” menu.
Click “Functions”.
Select a category “Statistical”
form down arrow.
Select “COUNTIF” from the list of
functions.
Click “OK” button.
Select the range which you want
to count nonblank cells using
drag and drop.
Type the criteria which is the
condition in the form of a number,
expression or text that defines
which cells will be counted.
Click “OK” button.
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Statistical functions (MAX)


Returns the largest value in a set of values
or within a range. For example, if A3, B3,
C3, D3 and E3 contains 20, 50, 80, 60 and
45 respectively then
=MAX(A3:E3)
return the maximum value in the range. In
this case, returns 80.
332
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Steps of “MAX” function
1.

2.

3.

4.

5.

Select the cell where you
want to return the MAX
value.
Click the down arrow of
“Autosum” command on the
standard toolbar.
Click the “MAX” (formula is
displayed in the cell which
you selected).
Select the range for return
the largest value using drag
and drop. (data range is
displayed in the brackets).
Type “Enter” key. (MAX
value is displayed). 333

Statistical functions (MIN)


Returns the smallest value in a set of
values or within a range. For example, if
A3, B3, C3, D3 and E3 contains 20, 50, 80,
60 and 45 respectively then
=MIN(A3:E3)
will return the lowest value in the range. In
this case, returns 20.
334
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Steps of “MIN” function
1.

2.

3.

4.

5.

Select the cell where
you want to return the
MIN value.
Click the down arrow of
“Autosum” command on
the standard toolbar.
Click the “MIN” (formula
is displayed in the cell
which you selected).
Select the range for
return the lowest value
using drag and drop.
(data range is displayed
in the brackets).
335
Type “Enter” key.

Statistical function (RANK)


Return the position or rank of a number
from a list of values. For example,
=RANK(A2,$A$3:$A$8,1)
returns the position of A2 as if the list was
sorted in ascending order.
336
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Steps of “RANK” function
1.
2.
3.

4.
5.
6.
7.
8.

9.
10.

Select the cell where you want to
return the position.
Click “fx” on the formula bar.
Type the “RANK” in the search
box.
Click “GO” button.
Select a function “RANK” from
the recommended list.
Click “OK” button.
Select the cell which you want to
find the rank.
Select the range of reference
which is an array of, a reference
to, a list of numbers.
Type “1” in the “Order” box if you
want to display descending.
337
Type “Enter” key.

Statistical functions (MODE)


Returns the most frequently occurring
value in a set of values
e.g. =Mode(A10:E10)
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Steps of “MODE” function.
1.
2.
3.

4.
5.
6.
7.

8.

9.

Select the cell where you want to
return the mode value.
On the “Insert” menu.
Click “Functions”.
Select a category “Statistical”
Select a “MODE” from the list.
Click “OK” button.
Select the range in the “Number1”
box where you want to calculate
the mode using drag and drop.
If you want to multiply other range,
insert that range in the “Number
2” box using drag and drop.
Click “OK” button.

Logical functions (IF)


It returns a specified value if a condition is
evaluated and found to be true and
another value if it’s false e.g. IF (mean
score>50,”Pass”, else ”Fail”. It will display
Pass. If values are more than 50 else
displays Fail.
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Steps of “IF” function.
1.
2.
3.
4.

5.
6.
7.

8.

9.

10.

Select the cell where you want to
return the IF value.
Click “fx” button on the formula bar.
Type “IF” in the search box.
Click “GO” button.
Select “IF” from the recommended list.
Click “OK” button.
Type any formula in the “Logical_test”
box which is any value or expression
that can be evaluated to TRUE or
FALSE.
Type any words or figure in the
“value_if_true” box you want to display
if value is true. You can nest up to 7 IF
function.
Type any other words or figure in the
“value_if_false” you want to display if
value is false.
Click “OK”

Date and time functions (TODAY)


Returns a number that represents today’s
date. The function takes no arguments.
For example, by the time of writing this
book,
=TODAY()
returned 17/05/2012
342
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Steps of “TODAY” function
1.
2.
3.
4.
5.
6.

7.

Select the cell where you want to
return the TODAY value.
On the “Insert” menu.
Click “Function”. (Insert Function
dialog box is displayed).
Select a category “Date & Time.
Select a function “TODAY” from
the list.
Click “OK” button. (other dialog
box is displayed which is written
“This function takes no
arguments).
Click “OK” button. (today’s date is
displayed where you select the
cell).

Date and time functions (NOW)


Returns the current date and time
formatted as date and time. It takes no
arguments. For example,
=NOW()
returned 17/05/2012 08:43
344
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Steps of “NOW” function
1.

2.

3.
4.
5.
6.

7.

Select the cell where you
want to return the “NOW”
value.
Click “fx” button on the
formula bar.
Type “NOW” in the search
box.
Click “GO” button.
Select a function “NOW” from
the list.
Click ”OK” button. (other
dialog box is displayed which
is written “This function takes
no arguments).
Click “OK” button. (today’s
date is displayed where you
select the cell).

Date and time functions (DATE)


Functions returns a serial number that
represents a particular date. MS-Excel
uses year 1900 serial number 1. for
example,
=DATE(112, 17, 5)
returns May 17, 2012. Year = (1900 +
112), month = 5, day = 17
346
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Steps of “DATE” function
1.
2.
3.
4.
5.
6.

7.
8.

Select the cell where you want to
return the DATE value.
On the “Insert” menu.
Click “Function”. (Insert Function
dialog box is displayed).
Select a category “Date & Time”.
Select a function “DATE”.
Click “OK” button. (Function
Arguments dialog box is
displayed).
Type “Year”, “Month” and “Day” in
the each box.
Click “OK” button. (Date is
displayed in the cell where you
selected).

Date and time functions (HOUR, MINUTE or SECOND)



Functions returns the current hour as
number 0 to 23, minute from 0 to 59 and
seconds from 0 to 59 respectively.

348
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Steps of “delete worksheet range”
1.
2.

3.
4.

Select the cell or range
of cells.
On the “Edit” menu.
Point to “Clear”.
Click “All”, “Formats”,
“Contents” or
“Comments”.

NB; alternatively press the
“Delete” key if you want
to delete contents. 349

Steps of “copy and paste cell(s) contents”
1.
2.
3.
4.
5.
6.

Select the range of cells
On the “Edit” menu
Click “Copy” or “Copy” command
on the standard toolbar.
Click the cell from where you want
the content to be copied.
On the “Edit” menu
Click “Paste” or “Paste” command
on the standard toolbar.

NB; shortcut key for copy
Ctrl + C
shortcut key for paste
Ctrl + V

350
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Steps of “cut and paste cell(s) contents”
1.
2.

3.

4.

Select the range of cells.
Click “Cut” command on
the standard toolbar.
Click the cell from where
you want the content to
be moved.
Click “Paste” command
on the standard toolbar.

NB; shortcut key for cut
Ctrl + X

Steps of “insert a new column or row”
1.

Position the pointer
where the new row
or column will
appear.

2.

On the “Insert”
menu.

3.

Click “Rows” or
“Columns”
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Steps of “delete a column or row”
1.

Select the column or
row to be deleted.

2.

On the “Edit” menu.

3.

Click “Delete”

Steps of “insert more worksheets”
1.

On the “Insert”
menu.

2.

Click “Worksheet”.
(a new worksheet is
added into your
workbook.
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Steps of “delete a worksheet”
1.

Click the
“Worksheet” tab
which you want to
delete.

2.

On the “Edit” menu.

3.

Click “Delete Sheet”.

Find and replace


MS-Excel provides capability to find and
replace data in a worksheet same as MSWord.

178

Steps of “Find” function
On “Edit” menu.
2. Click “Find”. (Find and
replace dialog box is
displayed).
3. Type the text to search
for in the “Find What”
box.
4. Click “Find All” or “Find
next”.
NB; shortcut key
Ctrl + F
1.

Steps of “replace” function
On “Edit” menu.
2. Click “Replace”. (Find and
Replace” dialog box is
displayed).
3. Type the word or phrase to
find in the “Find What” box.
4. Type the word or phrase to
replace the found word or
phrase in the “Replace
With” box.
5. Click “Replace All” or
“Replace”.
NB; shortcut key
Ctrl + H
1.
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Steps of “correcting spelling mistakes”
On the “Tool” menu.
2. Click “Spelling”
(Spelling dialog box is
displayed).
3. Click a button. Ignore
Once, Ignore All, Add to
Dictionary, Change,
Change All or
AutoCorrect.
NB; shortcut key
F7
1.

Steps of “Formatting label”
1.

2.
3.

4.
5.

6.

Highlight the cells that
have the text to be
formatted.
On the “Format” menu.
Click “Cells” (Format
Cells dialog box is
displayed).
Click the “font” tab.
Select the type of font,
font style, size,
underline, color and
other effects.
Click “OK” button.

180

Steps of “formatting numbers”
1.

2.
3.

4.
5.

6.

Highlight the cells that
have the numbers to be
formatted.
Click the “Format” menu.
Click “Cells”. (Format
Cells dialog box is
displayed).
Select the “Number” tab.
Select the type of
number from the
category list.
Click “OK” button.

Types of formatting numbers
Number

Meaning

General

General format cells have no specific number format.

Number

Used for general display of numbers e.g. 2345.23.

Currency

For displaying general monetary values e.g. $100, Ksh.10.

Accounting

Lines up the currency symbols and decimal points.

Date

Displays date in chosen format.

Time

Displays time in chosen format.

Percentage Multiplies the value in a cell with 100 and displays it as %.
Text

Formats cells to the treated as text even when numbers are
entered.

Custom

For a number format not predefined in MS-Excel, select
custom then define the pattern.
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Steps of “formatting borders”
1.
2.
3.
4.
5.
6.
7.

Highlight the range you wish
to insert borders.
On the “Format” menu.
Click “Cells”. (Format Cells
dialog box is displayed).
Click the “Border” tab.
Select a style of line and
color from the list.
Click any commands which
you want to draw the line.
Click “OK” button. (selected
range will have a border
around it).

Steps of “resize a column with mouse”
1.

2.

3.

Move the mouse pointer to
the right hand side line that
separates the column
headers for instance e.g. the
line between A and B.
Notice that the mouse pointer
changes from a cross to a
double arrow.
Click the mouse button and
hold it down so that you can
now resize the width of the
column by dragging it to the
size you wish. After dragging
to the required point release
the mouse button. The
column will have a new size.
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Steps of “resize a column using the “Format” menu
1.

2.
3.
4.

5.

6.

Select the column
where you want to
resize.
On the “Format” menu.
Point to “Column”.
Click “Width”. (Column
Width” dialog box is
displayed).
Type a width in the
column width box.
Click “OK” button.

Steps of “change row height”
1.

2.

Point to the line that
separate two row
numbers e.g. the line
between 1 and 2. The
mouse pointer becomes
a double arrow.
Drag the line until the
height of the row is as
required, then stop and
release the mouse
button.
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Steps of “auto adjust a column width and row height
1.

Place the mouse pointer
between columns or
heights which you want
to adjust. (mouse
pointer changes from a
cross to a double
arrow).

2.

Double click there.
(width or height was
changed a new size).

Steps of “Inserting rows”
1.

2.
3.

Select the cell where
you want to insert
the row.
On the “Insert”
menu.
Click “Rows” (new
rows was inserted
above of the cell
which you selected
and shift all the other
rows downward).
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Steps of “Inserting columns”
1.

2.
3.

Select the cell where
you want to insert
columns.
On the “Insert”
menu.
Click “Columns”.
(new column was
inserted left of the
cell which you
selected and shift all
the others to the
right).

Steps of “select a entire worksheet”
1.

Select the any cell.

2.

Pressing “Ctrl + A”
(whole worksheet
was highlighted).
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Steps of “using autoformat”
1.

2.
3.

4.
5.

Select a range e.g.
A2:N10 to set an
autoformat.
On the “Format”
menu.
Click “Autoformat”.
(AutoFormat dialog
box is displayed).
Select a autoformat
from the list.
Click “OK” button.

Data management


Sometimes worksheet data can be too
large and make it difficult for the user to
properly manage it. MS-Excel has tools
and features which enables the user to
manage their data.
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The feature includes








Sorting – with this feature spreadsheet can sort
information by row or columns alphabetically or
numerically in ascending or descending order.
Subtotals – MS-Excel can automatically
summarize data by calculating subtotals and
grand total values in a list.
Forms – this is a specially prepared template
that the user can use to enter data is a
worksheet.
Filtering – it’s a quick and efficient method of
finding and working with a subject of data in a
list. In MS-Excel there are two filtering
373
commands.

Steps of “data entry using forms”
1.

2.
3.
4.

5.

Position the cell
pointer in any cell
containing data.
On the “Data”: menu
Click “Form” (dialog
box is displayed).
Navigate through,
add new, delete or
find records.
Click “OK” button.
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Steps of “Sorting” function
1.

2.
3.
4.
5.
6.

7.

8.

Select any sell where you wish
sort by clicking its column
header letter.
On the “Data” menu.
Click “Sort”. (Sort dialog box is
displayed).
In the “Sort by” section, select
the field for sorting.
Select the sort order
descending or ascending.
Select the field for sorting and
sort order if you want to set
more.
In the “My data range has”
section, select “Header row” or
“No header row”.
Click “OK” button.

Types of filtering in a MS-Excel


Autofilter – uses simple criteria and
includes filter by selection. Autofiltering
can be applied to only one list on a
worksheet at a time.



Advanced filter – use more complex
criteria.
376
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Steps of “Autofiltering a list”
1.

2.
3.
4.

5.

Select a cell in the list
where you want to set an
autofilter.
On the “Data” menu.
Point to “Filter”.
Click “Autofilter”. (down
arrow buttons are
displayed in the header
row of data range).
You can sort or display
any data from the list.

Steps of “using custom autofilter”
1.

2.

3.

4.

Click the down arrow
button. (the list is
displayed).
Click “Custom”.
(Custom Autofilter
dialog box is
displayed).
Custom for filter as
you want.
Click “OK” button.
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Subtotals and grandtotals


Subtotals function is used
to summaries a
worksheet list to display
grouped subtotals and a
grand totals. The list is
grouped using a preferred
field. In MS-Excel to
insert subtotals, you first
sort the list so that the
rows you want to subtotal
are grouped together.
Figure right shows a
subtotaled list.

Steps of “generate subtotals”
1.
2.
3.
4.
5.
6.
7.

8.

Sort the data in ascending or
descending order.
Select a cell in the list.
On the “Data” menu.
Click “Subtotals”. (Subtotal dialog
box is displayed).
In the “At each change in” box,
select the field to use for grouping.
In the “Use function” box, select a
function you want to use.
In the “Add subtotal to” box, check
the columns that contains values
you want to calculate subtotal in
the check box.
Click “OK” button. (MS-Excel
automatically the list by calculating
subtotal and grand total values of
the list).

190

Input validation


To ensure that a user does not enter
invalid data, set the validation criteria. An
error message is displayed when data that
violates this rule is entered.

Steps of “set data validation” 1
1.

2.
3.

4.
5.

Highlight the range
of cells to validate.
On the “Data” menu.
Click “Validation”.
(Validation dialog
box is displayed).
Click “Setting” tab.
Select a validation
criteria each boxes.
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Steps of “set data validation” 2
6.
7.

8.

9.
10.
11.
12.

Click the “Input Message”
tab.
Type the title and message
in the each box.
Check “Show input
message when cell is
selected”. If you want to
display.
Click the “Error” alert” tab.
Select the style of error
alert from the list.
Type title and message in
the each box for error alert.
Click “OK” button.

Charts / graphs


These are pictures that represent values
and their relationships. A chart helps the
reader to quickly see trends in data and be
able to compare and contrast aspects of
data.

384
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Types of charts






Line chart
Columns chart
Bar chart
Pie chart
Scatter chart

NB; Figure right shows
more types of charts
available in MS-Excel.
385

Steps of “generate a chart” 1
1.

2.
3.
4.
5.
6.
7.
8.
9.

Click “Chart wizard”
command on the standard
toolbar. (chart wizard dialog
box is displayed).
Click “Standard Types” tab.
Select the chart type from the
list.
Select the chart sub-type
from the list.
Click “Next” button.
Click “Source Data” tab.
Select the data range using
drag and drop.
Select series in “Rows” or
“Column”.
Click “Next” button.
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Steps of “generate a chart” 2
10.
11.

12.

13.
14.

15.

Click “Title” tab.
Type the name of chart
title, X axis and Y axis in
the each box.
Click other tabs if you
want to add.
Click “Next” button.
Select place the chart
“As new sheet” or “As
object in”.
Click “Finish” button.

Editing and formatting charts


Once the chart is
created, its data
series patterns or
colours, size, location
and orientation can
be changed. Once
you select the chart, a
“chart” menu item is
added onto the menu
bar as shown in figure
right.
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Steps of “label a chart”
1.

2.

3.
4.

5.

Right click on the chart.
(shortcut menu is
displayed).
Click “Chart option”.
(Chart option dialog box
is displayed).
Click “Data label” tab.
In the “Label Contains”
section, check you want
to display.
Click “OK” button.

Steps of “inserting titles”
1.

2.

3.
4.

5.

Right click on the
chart. (shortcut
menu is displayed).
Click “Chart option”.
(Chart option dialog
box is displayed).
Click “Title” tab.
Type name of chart
title, X axis and Y
axis in the each box.
Click “OK” button.
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Steps of “inserting a legend”
1.

2.

3.
4.
5.

6.

Right click on the chart.
(shortcut menu is
displayed).
Click “Chart option”.
(Chart option dialog box
is displayed).
Click “Legend” tab.
Check “Show legend”
Select the place of
legend bottom, corner,
top right or left.
Click “OK” button.

Steps of “changing the chart location”
1.

2.

3.

4.

Right click on the
chart. (shortcut
menu is displayed).
Click “Location”.
(Chart Location
dialog box is
displayed).
Select the place of
chart where you
want to display.
Click “OK” button.
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Steps of “changing the chart type”
1.

2.

3.
4.
5.
6.

Right click on the chart.
(shortcut menu is
displayed).
Click “Chart Type”.
(Chart Type dialog box
is displayed).
Click “Standard Types
tab”.
Select the type of chart
from the list.
Select the sub-type of
chart from the list.
Click “OK” button.

Steps of “Print preview and page adjustment” 1
1.

Click “Print Preview”
command on the
standard toolbar.
(print preview
window is displayed).

2.

Click “Setup”
command. (Page Set
up dialog box is
displayed).
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Steps of “Print preview and page adjustment” 3
3.

In the “Page” tab, you
can set “Orientation”
and “Scaling”.

4.

In the “Margins” tab,
you can set each
margins.

Steps of “Print preview and page adjustment” 3
5.

6.

7.

In the “Header/Footer”
tab, you can insert some
data e.g. characters,
page number, picture or
etc which you want to
display.
In the “Sheet” tab, you
can set print area, title,
order and other options.
Click “OK” button.

198

Steps of “Print from print preview window”
1.

2.

3.

4.

Click “Print” command.
(Print Preview window is
closed and Print dialog
box is displayed).
Select the printer from
the down arrow list.
Select other options
“Print range”, “number
of copies” or etc.
Click “OK” button.

In creation of charts there must be
Data range – this is a rectangular block of
cells that provides the base data that is
used to create the chart.
 Label – each representation of data on a
chart can either be labelled by a value or
text.
 Legend – this is a key that explains what
each colour or pattern of the data
representation in the chart means.
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Review questions 1
1.
2.
3.

4.
5.
6.
7.
8.
9.
10.
11.
12.

Define a spreadsheet.
What is an electronic spreadsheet?
State four advantages of an electronic spreadsheet over:
A) Manual spreadsheets.
B) Electronic calculator.
Explain three components of a spreadsheet.
State five application areas of spreadsheets.
What is forecasting? How can a spreadsheet help a person to do this?
Give any two methods you can to start MS-Excel.
Differentiate between a formula and a function.
Write the following formula as absolute =F10+G20.
The formula =A1+C2 is initially typed in cell D1. what will it be when copied
to cell E1?
Differentiate between a worksheet and a workbook.
How can you close a MS-Excel worksheet without exiting from the
399
application?

Answer of review questions 1-1
1.
2.

3.

A ledger sheet is made up of rows and columns for entering/writing data.
A computer software that looks like the manual ledger sheet with rows and
columns used for entering data and manipulating numerical data.
A). Manual spreadsheet.
1. Electronic spreadsheet has large worksheet as compared to manual
worksheet.
2. Electronic spreadsheet has inbuilt formulae called functions that are
nonexistent in manual worksheet.
3. Electronic spreadsheet uses the power of the computer quickly carry out
operations.
4. Superior formatting and editing qualities of electronic spreadsheet make
it better than the manual worksheet.
B). Electronic calculator.
1. Has more memory than a calculator.
2. Able to perform more complex and even logical operations but a
calculator cannot.
3. Uses large storage capacity of computer that a calculator doesn’t have.
400
4. Large work area that a calculator does not have.
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Answer of review questions 1-2
4.
5.
6.

7.
8.

9.
10.
11.
12.

Worksheet, database and graphs
Scientific applications, accounting, forecasting, data
management and mathematical operations.
Predicting future trends using the goal seek command.
A). Double click the shortcut icon on the desktop or.
B). Select MS-Excel from the programs menu.
Formulae – arithmetic and user developed while
functions – inbuilt formulae. Some of them are macro
functions.
=$F$10+$G$20
=B1+D2
One page in a workbook is called a worksheet.
Click the File-close command.
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Review questions 2
1.

2.

3.
4.
5.
6.
7.

8.

State the effect of pressing each of the following key combinations on the
cell pointer:
A) Right arrow key
B) Shift + Tab
C) Ctrl + Home
Define each of the following:
A) Cell
B) Row
C) Column
Write the equivalent R1C1 reference for G20.
What is a name reference? How can you accomplish this in Excel?
What is a template? Explain how can start a spreadsheet template in MSExcel.
State four data types acceptable to spreadsheets and explain each of them.
Differentiate between single and multiple cell referencing.
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What is a range?
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Answer of review questions 2
1.

2.

3.
4.
5.

A). Moves cell pointer to the cell on the right.
B). Moves cell pointer to the cell on the left.
C). Moves cell pointer to cell A1
A). Intersection between row and column.
B). Horizontal arrangement of cells.
C). Vertical arrangement of cells.
R20C7
It is a cell reference that is a name. To name a range, select it then type a
name in the name box then press enter key to apply the name.
A pre-formatted worksheet document used as a master layout for others. To
start a template:
i.
ii.

6.
7.
8.

Click File-New command.
In the new dialog box click the spreadsheet solutions tab then double click the
template that you wish to start.

Values, Labels, Formulae, Functions.
Single referencing – for one cell, e.g. A1 while multiple referencing – for
many cells, e.g. A1:B3
403
A group of rectangular cells.

Review questions 3


Match the following
statements with the
correct answers.
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Answer of review questions 3
a.

C

b.

A

c.

B

d.

D
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Review questions 4
1.

Differentiate between the following
terms:
A)
B)
C)
D)

2.

Formula and function.
Relative and absolute cell referencing.
Relational and arithmetic operators.
DATE() and TODAY() function.

The formula $A1 + B$1 was entered cell
C1. How would the formula be, if copied
to F2?

406

203

Answer of review questions 4
1.

Differentiate
A)
B)
C)

D)

2.

Formulae are mathematical expressions while a
function is an inbuilt formula.
Relative reference adjusts to reflect the new location
while absolute reference do not change.
Relational operators returns a boolean value (True
or False) while arithmetic operators are used for
performing basic arithmetic operations.
DATE() returns serial number that represents a
particular data while TODAY() returns a number that
represents today date.

$A2 + E$1
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Revision questions 1
Describe two ways to complete an entry into a cell.
2. How does MS-Excel determine that an entry is a text or
a formula?
3. How do you clear (erase) the contents of a cell?
4. How can you copy a formula?
5. Explain how you can print a worksheet in landscape
orientation.
6. How can you insert rows in a MS-Excel worksheet.
7. Differentiate between copying and moving data in a
worksheet.
8. What is the autoformat feature?
9. Explain the term filter. How is a filter different from a hide
command.
408
10. Why are forms needed in MS-Excel.
1.
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Answer of revision questions 1-1
1.

2.
3.
4.

5.

A). Select a cell then type from the keyboard OR.
B). Select a cell then double click the formula bar and type the
value in the bar.
Formulae have equal sign at the beginning while text has
either letters or a combination of letters and numbers.
Select cell then press delete key on the keyboard.
Click the cell that has the formula then click the Edit-Copy
command. Click the cell to copy to then click the Edit-Paste
command.
1). Click File-Page setup command, choose landscape.
2). On the margins tab of the page setup dialog box, select the
page orientation then click OK button.
409
3). Send document to printer.

Answer of revision questions 1-2
6.
7.

8.
9.

10.

Click the Insert-Rows command.
Copying – makes duplicate of data.
Move – relocates data from one section of
document to another.
A feature that applies a pre-formatted feature
on a selected range of the worksheet.
A filter hides all the rows that do not have a
particular selected value in a column while
hides the entire row/column.
A). A form helps users to enter values in a table
with minimum errors.
B). It hides the base data of the table hence 410
enhances data security.
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Revision questions 2
1.
2.
3.
4.
5.
6.
7.
8.
9.
10.

Give two examples of charts that you know.
Why are charts important in a spreadsheet?
Explain the concept of subtotals.
What is sorting? Explain how you can sort data in
ascending order.
Give three number formats in MS-Excel.
What re worksheet borders? Explain how to implement
them in the worksheet.
What is the difference between printing a range and
whole workbook.
Explain two ways of changing the font size in MSExcel.
What is a legend?
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Which chart type will be most suitable to show trends?

Answer of revision questions 2-1
1.

2.
3.
4.

5.

Pie charts, line charts, bar charts, scatter charts, column
charts.
A chart represents sets of data in pictorial form hence
makes the data easier to understand and interpret.
Subtotals command groups and finds totals of similar
data records in the spreadsheet.
Sorting is arranging data values in a particular order.
a. Highlight data range to be sorted.
b. Click Data-Sort command.
c. In the sort dialog box, select the order of sort in the
key field as ascending then click OK.
Number, text, fraction, currency, scientific and time etc.

412
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Answer of revision questions 2-2
6.

Are printable borders inserted around cell borders.
Select the range then click Format-Cells command.
On the Borders tab, select the border styles then click
OK to apply.
Print range – print a selected workbook group of cells in a
worksheet.
Print whole – print the entire workbook that has data.
A). Highlight range then select font size from formatting
toolbar.
B). Highlight cell, click format – cell – Font – Size – Adjust.
Is a key that shows the meaning of different data values in
a graph that are usually represented by different colours.
A line chart.

6.
7.
7.

8.

9.
10.
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Practical activity 1
Row Label

Value

1.

Rent

650

2.

Utilities

13,200

3.

Salaries

15,700

4.

Loan
repayment

1,700
1,040

6.

Insurance
policy
Office supplies

7.

Fixed costs

44,290 4.

5.

1.

2.

3.

12,000

Study table right and
enter its values in a
worksheet.
Save the worksheet as
My Budget.
Select the range i.e.
from top to bottom and
press delete key on the
keyboard.
Click Edit – undo to
414
reverse the delete action.
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Practical activity 2


Using the grading
system given below,
create a worksheet
that can be used to
calculate end of term
examination marks
and assign grades
based on the
following grading
system:
save the workbook as
Exam Grades.

Marks

grade

80-100

A

70-79

B

60-69

C

50-59

D

40-49

E

Below 40

Fail
415

Practical activity 3
1.

2.

3.

4.

Prepare the
following worksheet.
Save the worksheet
as Account.
Calculate the total
amount.
Print the worksheet
on landscape
orientation.
416
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Practical activity 4
Financial comparison for October 2011.
MIWANI ENTERPRISES.
1. Save the worksheet as Miwani.
2. Add up the total for:
A) Income; and
B) Expenses on the budget column.
3. Get the surplus (profit or loss) in both columns by
subtracting the Total Expenses from the Total
Income.
4. What is the difference between Actual transaction
and the plan (Budget). Get the difference by
subtracting Budget surplus form Actual surplus.
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Practical activity 5


Enter the following data
for 3 weeks’ sales in a
bookshop.
Save the worksheet as
bookshop sales on your
computer.
B) Get the totals.
C) Draw a bar graph that
compares values for the
week starting 15th march
and save it on a separate
worksheet.
D) Create a pie chart that
compares the sales for all
the three Wednesdays.
418
A)
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Chapter 5
Database

419

Introduction


A data base is a collection of data stored
in a computer system in some organised
manner to make the retrieval of the data
easy.

420
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Database concepts 1


Traditionally filling methods
 This

is the old way of organising files. This
method is where data is stored within a single
paper file or table.

421

Database concept 2


Computerised database
 This

database use database management
system software to manipulate data.
Examples of DataBase Management
Software (DBMS) include:
MS-Access
 Oracle
 Fox Pro
 Dbase IV


422
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Disadvantages of traditional methods


Unnecessary duplication of data.



Boredom and time wasting while
searching for a record.



Misleading reports due to poor data entry.



Poor update of records.
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Functions of DBMS
Allow the user add or delete records.
 Update or modify existing records.
 Organise data for easy access, retrieval
and manipulation.
 Ensure security for data in the database.
 Keeps statistic of data items in database.


424
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Database models 1




Flat files – this model of
database holds only one
set of data and is not any
different from the manual
files e.g. the library
catalogue.
Hierarchical model – in
this model items are
arranged in hierarchical
(tree) form. To access
level one data items, you
have to first access level
one data items. A specific
single path leads to each
item at lower levels.
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Database models 2




Network model – in this model,
lines are used to express the
relationship between different
data items, forming a network
of items. Access of one item
can be through many paths
and from any item.
Relational model – in this
model, related data items are
stored together in structures
called relations or tables.
Relationship can be created
between tables such that a
record or records from one
table relates to another in
another table.
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Database models 3


Object oriented model – in this model,
database is a complete program built to
hold a collection of objects, which have
both properties and behaviour.
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Features of database 1




Tables/file structure –
this is database
structure that is used
to hold related
records.
Queries – this is a
tool used to search
for or question a
database on specific
records.
428
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Features of database 2




Form/Screen input – this
is a graphical interface
that resembles the
ordinary paper form used
to collect data. It enables
the user to view and enter
data into a table.
Report – database
provides the user with a
tool for generating reports
from a table or query.
429

Features of database 3


Modules – this tool is like the macro but
it’s more precise in the sense that you
have control over the actions taken.



Macro – this tool enables the user to
automate frequently performed procedures
or tasks.
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Data organisation in a database
Field – this is a character or a logical
combination of characters that represent a
data item e.g. in a class list the Admno is a
field.
 Records – this is a collection of related fields
that represents a single entity e.g. student
name, sex, age, marks etc.
 File – this is a collection of related records.
 Database – this holds all related files or
tables.
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Creating a database using MS-Access
1.
2.
3.

4.
5.

6.
7.
8.

9.

10.

Click “Start”.
Point to “Programs/All Programs”.
Point to “Microsoft Office”.
Click “Access 2003” (application is
opened).
On the task pane, click down arrow
sign of click “Getting Started”
(shortcut menu is displayed).
Select “New file”.
Click “Blank database” (File New
Database dialog box is displayed).
Select the location where you want
to create the database from the
arrow down list.
Type the name of database in the
file name box.
Click “Create” button.
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Microsoft Access screen layout

Steps of “exiting from Access”
1.

On the “File” menu.

2.

Click “Exit.

NB: shortcut key
Alt+F4
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Steps of “creating a table structure” 1
1.
2.

3.

4.

Click “Table” tab.
Click “New”. (New
Table dialog box is
displayed).
Select “Design View”
from the list.
Click “OK” button.
(Table is displayed).

Steps of “creating a table structure” 2
5.

Type a unique name
for each field in the
table.

6.

Select “Data Type”
from the down arrow
list.

7.

Add the other fields.
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Steps of “creating a table structure” 3
8.

9.

10.

11.

After you add in other
fields, click “Save”
button on the standard
toolbar. (Save As dialog
box is displayed).
Type the name of table
in the “Table Name”
box.
Click “OK” button.
(Message box is
displayed).
Access will ask you
whether you want to
create a “Primary Key”,
click “Yes”.

Rules of a filed name in the table


A field name must start with a letter and
can be up to a maximum of 64 characters
including letters, numbers, spaces and
punctuation.
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Field data types 1








Text – it includes alphabetic letters, numbers,
spaces, punctuation etc. This data type is used
in field that needs no calculations.
Number – this field is made up of numeric
numbers 0-9 that are to be manipulated
mathematically.
Memo – this is made up of alphanumeric data
used if you need to enter several paragraphs of
text.
Data/Time – identify a field either as date or time.
439

Field data types 2






Currency – identify a numeric value that have
decimals or fractions used when dealing with
monetary values.
Autonumber – it’s a numeric value used if you
want MS-Access to automatically increment the
values in the field.
Yes/No – it’s a logical field where an entry is
either a “Yes” or “No” “True” or “False”. Ole
object – this data type is used with graphical
user interface application for inserting graphical
objects.
440
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Field properties settings


As you create more and
more complex tables, you
will find a need to use field
properties to specify finer
details related to fields and
table entries expected. Field
properties depend on the
type of field selected. For
example, when you click on
a “Text” field, then the
“General” tab, you will see
properties associated to text
data type as shown in figure
right.

Field properties 1


Field size – allow the user to set the number
of characters in a field instead of the default
50 for text fields. For numeric fields integer,
bytes, single, double or long integer is used.



Format – determines how information
appears on the screen and when printed e.g.
you can format number to scientific,
currency, % etc
442
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Field properties 2


Decimal places – for number or currency
fields you can specify the number of
decimal place.



Input mask – it automatically formats the
field entry into specified format e.g. a
number 02042426090 and the input mask
is set as 000-(0000)-(0000) it will
automatically display as 020-4242-6090.
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Field properties 3


Caption – it’s a more descriptive name for
a field to be used in a table or a form
display e.g. a caption Fname could be
First name.



Default value – this is a value that will
appear automatically in the form if nothing
is entered by the user to change it e.g.
Date () automatically displays current date.

444
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Field properties 4


Validation rule – it’s a logical expression
that restricts values to be entered in a field
e.g. to restrict value entered in a field to be
between 0 and 100 type > = 0 and < = 100.



Validation text – this is message that
appears once the validation rule is violated
e.g. you may enter a validation rule for the
above rule to display “Enter a number
between 1 and 100”
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Field properties 5


Required – Determines if an entry must be
made in the field before you proceed to
the next field or record.



Allow zero length – allows the user to
proceed without making any entry in the
field set as zero length.
446
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Field properties 6


Indexed – it facilitates the organisation of
records for easy search.



Primary key – it’s a field that enforces
uniqueness in a table so that one record is
not entered twice.



Index – this is a feature used to speed up
search and sort operations in a table.
447

Primary key and indexes.


An index is a key(s) used to speed up searching
and sorting records in a table, while a primary
key is an index that uniquely identifies each
record stored in the table. A primary key
prevents the user from making null or double
entries into a table. Access uses the primary key
to order records, and control redundancy. Once
a field is set as primary key, the datasheet in
automatically indexed or sorted using the
primary key.
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Steps of “set a primary key”
1.
2.

3.

Open the table in
design view.
Select the field you
want to set as the
primary key by
clicking in the row
header to the left the
“Field Name”.
Click “Set Primary
Key” button on the
tools bar.

Steps of “set another field as an
index other than the primary key”
1.
2.

3.
4.

5.

6.

Open the table in design view.
Click “Indexes” button next to
the primary key. (Indexes
dialog box is displayed on the
screen as shown in figure right
above.
In the “Index Name” column,
type the name of the index.
In the “Filed Name” column,
select the corresponding
fieldname.
In the “Sort Order” column,
select “Ascending” or
“Descending”.
“Close” dialog box.
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Steps of “adding new records”
1.

Double click the
table icon. (the table
is displayed in
datasheet view”.

2.

On the “Insert”
menu.

3.

Click “New Record”.

Symbols of row header.








An arrowhead indicates
that no new data entry or
edit is pending.
Asterisk symbol marks a
blank record below the
current entry.
Pencil symbol indicates
that the current record
entry is not yet saved.
Record locked indicates
that the current record is
being edited by another
user in a multi-user or
networked environment.
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Steps of “deleting records”
1.

Click the record you
want to delete.

2.

On the “Edit” menu.

3.

Click “Delete”.

Steps of “editing fields”
1.

Double click the field
you want to edit.

2.

Replace the cell
content.
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Steps of “searching for records”
1.
2.
3.

4.

5.

On the “Edit” menu.
Click “Find”.
In the “Find What” box,
type the field to search.
Select other options for
find “Look In”, Match or
etc.
Click “Find Next” button.

NB; shortcut key
Ctrl + F

Steps of “Replace a records”
1.
2.

3.
4.

5.
6.

On the “Edit” menu.
Click “Replace” (Find and
Replace dialog box is
displayed).
In the “Find What” box, type
the name of field to replace.
In the “Replace with” box,
type field to replace with
respectively.
Select other options for find
“Look In”, Match or etc.
Click “Replace” or “Replace
All” button.
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Steps of “copying records”
1.
2.
3.

4.
5.
6.

Select the record(s) to
be copied.
On the “Edit” menu.
Click “Copy”.
Select the target
datasheet to copy.
On the “Edit” menu.
Click “Paste”.

NB: shortcut key for “Copy”
Ctrl + C
shortcut key for “Paste”
Ctrl + V

Steps of “moving records”
1.

2.

3.

4.

Select the record(s) to
be moved.
Click “Cut command on
the standard toolbar.
Select the target
datasheet to move.
Click “Paste” command
on the standard toolbar.

NB; shortcut key for move.
Ctrl + X
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Steps of “Sorting records”
1.

2.

3.

4.
5.

Open the table in
datasheet view.
Select the records to
be sorted.
On the “Record”
menu.
Point to “Sort”.
Click “Ascending” or
“Descending”.

Steps of “Filtering records”
1.

2.
3.
4.
5.
6.

7.

Open the table in
datasheet view.
Select the records to be
filtered.
On the “Record” menu.
Point to “Filter”.
Select the type of filter
you want to apply.
In the datasheet, click a
down arrow of the field
to set the filter option.
Click “Apply Filter”
button on the toolbar.
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Steps of “adjust the column size”
1.

2.

Point to the column
border between the
field’s header.
(mouse pointer sign
will be changed to
black cross sign).
Change the column
size up to where you
require using drag
and drop.

Steps of “adjust the row height”
1.

2.
3.

4.

5.

Point to the border between
two rows in the row header.
(mouse pointer sign will be
changed to black cross
sign).
On the “Format” menu.
Click “Row height”. (Row
Height dialog box is
displayed).
Delete current row height
and type the new row height
which you want to adjust.
Click “OK” button.

231

Steps of “reorder fields”
1.

2.

Select the column of
the field you wish to
move by pointing to
the desired file
name.
Drag the column
right or left to the top
of the field where
you want your field
to appear and then
drop.

Modifying table structure




Once you create a table, you may need to add
more fields, remove some fields, reorder the
fields or change fields data types and properties.
Before you modify the table it is important to
save a copy to avoid losing everything in case
you make a mistake.
If a table contains data and you make changes
to the field data type, MS-Access may refuse to
implement the changes. To avoid this problem,
exit without saving and delete all the records
from the table then return to the design view.
You can then import a copy or copies of tables
you backed up.
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Steps of “make a copy of your table”
1.
2.

3.

4.
5.

On the “File” menu.
Click “Save As/Export.
(dialog box is
displayed).
Choose whether to
save to another
(external) database or
the current database.
Type a new name for
your table.
Click “OK” button.

Steps of “modify the original table”
1.

2.

3.

Open the table in
design view.
Select the field or
fields to be modified
and make the
necessary changes.
Click the “Save”
button to save the
changes.
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Importing tables


You can import a table from another
database or a spreadsheet into your
database.

Steps of “import a table or a worksheet”
1.
2.

3.
4.
5.

6.
7.
8.

On the “File” menu.
Point to “Get External Data”.
Click “Import”. (Import dialog
box is displayed).
Select the database you
wish to import data from.
Click “Import” button.
(Object dialog box is
displayed as shown in figure
below).
Click “Table” tab.
Select the table(s) you wish
to import.
Click “OK” button.
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Form designs


A form is an interface that
enables the user to view and
make data entries into an
underlying table more easily.
 A form is designed using
graphical objects called
controls.
 A control is an object
such as textbox,
checkbox, command
button or shapes placed
on form design grid to
display data or perform
469
actions.

Types of controls


Bound – in this the source of data is a field
in a table or query.



Unbound – this control is not connected to
any data source.

470
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Form designer


You design or modify
a form layout by
dragging these
controls to the
required position.
Figure right shows a
form designer for a
table called exam
entry.

Creating a form layout using form wizard


To create a form layout, you can either use the form
wizard or start from scratch. Using the form wizard you
can create either a columnar, a tabular a datasheet or
a justified form layout.
 Columnar

form: the fields for each record are displayed
down a column i.e. each value displays on a separate line
with field labels to the left.
 Tabular: records are displayed from left to right across the
page and labels appear at the top of each column. Each row
represents a new record.
 Datasheet: the form resembles a table datasheet view.
 Justified: one record occupies the whole form.
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Steps of “create a form using the wizard” 1
1.
2.

3.
4.

5.

Click “Form” tab.
Click “New”. (New Form
dialog box is displayed).
Select “Form Wizard”.
Select the name of the
table or query that
includes the data you
want to add into the
form from down arrow
list.
Click “OK” button.

Steps of “crating a form layout using form wizard” 2.
6.

7.
8.

9.

Select the fields to
add into the form by
clicking the “>”
button or click “>>”
to add all fields.
Click “Next” button.
Select the layout you
wish to use
“Columnar”, Tabular”
or etc.
Click “Next” button.
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Steps of “crating a form layout using form wizard” 3
10.

11.
12.

13.

Select the style you
wish to use “Blends”,
“Blueprint” or etc.
Click “Next” button.
Type the name of the
form title in the box.
Click “Finish” button.
(MS-Access will
automatically display
the form on the screen).

Creating a form using autoform wizard


You can easily create a form using the
“Autoform wizard”. This wizard creates a
form for you automatically by asking you
very minimal questions. The form includes
all the fields from the selected table.
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Steps of “construct an autoform”
1.
2.
3.

4.

5.
6.

7.
8.

Click “Form” tab.
Click “New”. “New Form
dialog box is displayed).
Select autoform layout
“Columnar”, “Tabular” or etc.
In “Choose the table or query
where the object data
comes”, select the table or
query form from down arrow
list you wish to create a form
for.
Click “OK” button.
Click “Save” button on the
toolbar. (Save As dialog box
is displayed).
Type the name of the form.
Click “OK” button.

Steps of “creating a form from scratch”
1.
2.
3.
4.

5.

6.

Click “From” tab.
Click “New”. (New Form dialog
box is displayed).
Select the “Design view” from the
list.
In “Choose the table or query
where the object data comes”,
select the table or query form
from down arrow list you wish to
create a form for.
Click “OK” button. (a form with
controls for all fields is
displayed).
Arrange the form as you want.

239

Steps of “add controls onto a form”
1.
2.

3.

4.

On the “View” menu.
Click “Field list”. (the
field of the table you
selected is
displayed).
Drag and drop each
field and arrange
them on the grid.
Click “Save”
command on the
toolbar.

Adding and displaying records


The form provides the user
with navigation buttons
located at the bottom that
can be used to navigate the
form as shown in figure
below. The functions of the
buttons can be summarized
from left to right as follows:
1.
2.
3.
4.
5.

Displays the first record in the
table.
Displays the previous record.
Displays the next record.
Displays the last record.
Used to add a new record.
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Steps of “format controls on a form” (resize)
1.
2.

3.

4.

Open the form in design
view.
Select the field which you
want to resize. (place
holders are displayed
around field).
Place the mouse pointer on
the place holder. (mouse
pointer sign will be changed
to a double-sided arrow
sign).
Resize using drag and
drop.

Using queries


Queries are the fastest way to search for
information in a database. It also enables
the user display specific records and also
perform calculations on field from tables.

482
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Types of queries


Select query – most commonly used, it is
used for searching and analysing data in
one or more tables. It lets the user specify
the search criteria.



Action query – these are used to make
changes to many records once.
483

Types of action queries
Update – updates data in table.
 Append query – adds data in a table from
one or more tables.
 Make table query – creates a new table
from a dynast.
 Delete query – deletes specified records
from one or more tables.


484

242

Steps of “creating a select query using wizard” 1
1.
2.
3.

4.
5.

6.

7.

Click “Queries” tab.
Click “New”. (New query
dialog box is displayed).
Click “Simple Query Wizard”.
Click “OK” button.
Select the name of the table
or query that includes the
data you want to add into the
query from down arrow list.
Select the fields to add into
the query by clicking the “>”
button or click “>>” to add all
fields.
Click “Next” button.

Steps of “creating a select query wizard 2”
7.

Select “Detail” or
“Summary”.

8.

Click “Next” button.

9.

Type the title name of
query in the box.

10.

Click “Finish” button.
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Steps of “creating a select query from in design view” 1
1.
2.
3.
4.

5.

6.
7.

Click “Queries” tab.
Click “New”. (New query
dialog box is displayed).
Select “Design View”.
Click “OK” button. (Show
Table dialog box is
displayed).
Select table, query or both
which you want to add into
the query from each tab.
Click “Add” button.
After you add, click “Close”
button.

Steps of “creating a select query from in design view” 2


The query design grid
opens. In MS-Access
it is called “Query-ByExample” (QBE). This
lets the user to design
a query. Figure right
is QBE grid for a table
called Exam.
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Parts of the query grid









Field row – fields from a table or tables to be used are
arranged in this row. Each field should occupy its column.
Table row – indicates the table providing the fields.
Sort row – by clicking the down arrow in the sort cell, you
can specify the sort order i.e. ascending, descending or not
sort.
Show row – by clicking the Show box, you specify whether
to display the field in the query results. When the box is not
checked, the field will not be displayed.
Criteria row – this is where you type conditional statement
that will be used by the query to display specific records.
Or row – used to specify an alternative condition e.g. if you
want to display records with a field called City, with items
Nairobi or Embu, type Nairobi in criteria cell and Embu in
the Or cell.

Specifying the criteria search


To search for a particular set of records,
the users have to enter a conditional
statement in the criteria row. For example
if you have a table called employees with
one of the fields as salary, you can display
all the employees earning more than Shs.
5,000 by typing>5000 in the criteria row,
salary column.
490
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Other examples of specifying the criteria search 1






To define criteria, use either relational or logical
operators. Relational operators include less than (<),
greater than (>), greater than or equal to (>=), less
than or equal to (<=), not equal to (<>) and equal to
(=). Logical operators include AND, OR and NOT.
Use AND to display values in a specific range. For
example, to display records from the employees table
with salaries above 4000 but less than 6000, type,
>4000 AND <6000 on the criteria row in the salary
column. All the employees who meet this condition will
be displayed.
Use OR if you wish to get either one of two values. For
example, if you wish to get those employees either in
Nairobi OR Embu.

Other examples of specifying the criteria search 2






If you want to display data in a particular range, use the
word Between. For example, instead of typing, >4000 AND
<6000, type Between 4000 And 6000.
If you want to list all records except those that you do not
want to see, use NOT. For example, if you type NOT 6000
in the salary column of the employees table, all employees
records will be displayed except those with their salary as
6000.
To display records you are not sure of the field name but at
least you can remember a few characters, use LIKE and the
wildcards. Wildcards are special symbols mostly an asterisk
and a question mark used in place of other characters. For
example, to display all names starting with “Sm” followed by
any other character, type Like Sm? Like */*/1993 lists
records created in 1993 regardless of the day or month.
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Steps of “add fields into the query grid”
1.

Open the query in
design view.

2.

From the field list of
the underlying table,
drag each field and
place it in the field
row.

Steps of “saving the query”
1.

Click “Save” button
on the toolbar or
from the “File” menu.
(Save As dialog box
is displayed).

2.

Type name of the
query in the box.

3.

Click “OK” button.
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Steps of “running the query”


Click “Run” button on the
toolbar as shown in figure
right above or “Run”
command from the “Query”
menu. (results of the query
is displayed).

NB: you can also view the
results of your query any
other time by selecting the
query, then click “Open”
button from the database
window.

Steps of “sorting the dynaset”
1.

Click the down arrow
button of the “Sort”.
(list is displayed).

2.

Select “ascending”
or “descending”.
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Steps of “delete fields from the query grid”
1.

2.

3.
4.
5.

Open the query in
design view.
Select the field column
you wish to delete.
On the “Edit” menu.
Click “Delete”.
After you delete, click
“Save” command on
the toolbar to save the
changes.

Steps of “adjust the column size in a query”
1.

2.

3.

4.

Open the query in design
view.
Position the mouse pointer
at the boundary that
separates columns. (mouse
pointer sign will be changed
block cross sign).
Double click on the
boundary to autofit cell
content.
Click “Save” command on
the toolbar to save the
changes.
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Steps of “modify a criteria statement, select query”
1.
2.

3.

4.

Open the query in
design view.
Select the field of criteria
which you want to
modify, then change the
criteria statement as you
desire.
Click “Save” command
on the toolbar to save
changes.
Click “Run” command to
display the results of the
query for test whether
the changes have been
effected.

Performing calculations in a query.


Unlike tables, queries let the user perform
mathematical calculations on numeric data.
You can perform calculations in a query by;
A)

B)

Creating basic formulae – to create a formula
that calculates the total marks in an underlying
table e.g. Exams table.
Using Total functions – with a query, you can
analyze all record fields using the inbuilt
functions such as Sum, Average, Minimum and
Maximum etc.
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Steps of “creating basic formulae”
1.
2.

3.
4.

Open the query in
design view.
In an empty cell, type an
expression that includes
a field name of each as
“Amount: [Quantity] *
[Unit Price] as shown in
figure right above.
Click “Save” command
on the toolbar.
Click “Run” command
on the toolbar. (the
results of the
calculations is
displayed).

Steps of “use the total functions”
1.
2.

3.

4.
5.
6.

Open the query in design
view.
Click “Totals” command on the
tool bar. (Totals row is
displayed which is located
between “Table” row and
“Sort” row).
For each field to be analyzed,
click its cell in the “Total” row,
and then select any of the
functions from arrow down list
of “Total” row.
Set criteria and other options.
Click “Run” command on the
toolbar to preview the results.
Click “Save” command to save
the changes.
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Steps of “printing a query”
1.
2.

3.
4.
5.
6.
7.

Click “Queries” tab.
Open the query in
datasheet view you
want to print.
On the “File” menu.
Click “Print”.
Select the printer
from arrow down list.
Set the other printing
options.
Click “OK” button.

Relationship in tables
Entity – an entity is a thing or object of
significance, whether real or imagined,
about which information needs to be
known or held.
 Attribute – an attribute is any detail that
serves to qualify, identify, classify, quantify
or express the state of an entity.
 Candidate key – it’s any attribute or set of
attributes can be used to uniquely identify
a row in a table.
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Types of relationships
One-to-one relationship – for a particular
field in one table there is only one
matching record in the related table.
 One-to-many relationship – for a particular
field in one table there are several
matching records in another table.
 Many-to-many relationship – for particular
records in one table there are several
matching records in the other table.
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Steps of “defining relationship between tables” 1
1.
2.
3.

4.
5.
6.
7.

8.

Open the database.
On the “Tools” menu.
Click “Relationship. (Show
Table dialog box in
Relationship is displayed).
Select the table from Table
tab.
Click “Add” button.
After you add, click “Close”
button.
Click the field of first table
which you want to create
relationship.
Drag it to the second table
then drop. (Edit Relation ship
dialog box is displayed).
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Steps of “defining relationship between tables” 2
7.

8.
9.

Make sure “Enforce
Referential Integrity” is
checked to ensure that all
records entered in the
related table exist in the
primary table.
Set other options if you
want.
Click “Create” button.
(Black line is displayed
between two tables).

NB; the field used to create the
relationship must be of the
same type and properties.

Steps of “create a query based on related tables”
1.
2.

3.
4.
5.
6.
7.

8.
9.

Open the query in design view.
Click “Show Table” command on
the toolbar. (Show Table dialog
box is displayed).
Select the tables you want to
base your query on.
Click “Add” button. (query is
displayed).
After you add, click “Close”
button.
Click the field of first table which
you want to create relationship.
Drag it to the second table then
drop. (Edit Relation ship dialog
box is displayed).
Click “Run” command to run.
Click “Save” command to save.
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Creating reports


Like in forms, a report
layout is also
designed by placing
controls on to the
report designer as
shown in figure right.

Parts of a report









Report header – this contains unbound controls that displays
title of the report.
Page header – contains heading or labels data items to be
displayed in every column.
Detail – holds bound controls that display data items for the
table or query it was created from.
Detail – holds bound controls that display data items for the
table or query it was created from.
Page footer – holds a control that is to be displayed on every
page such as the page number and date. For example =Now()
displays the current date and time as set in the system clock.
Report footer – used to display summary from a report such as
the grand total for numerical data in a particular field column.
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Creating a report


Using wizard
 Just

like the form wizard, report wizard takes
the user through a number of steps by
answering a few questions and MS-Access
automatically does the rest.



In design view
 Just

like with forms, you can create a report in
design view by placing control on the report
design grid.

Steps of “create a report layout using wizard” 1
1.

Click “Report” tab.

2.

Click “New”. (New
Report dialog box is
displayed).

3.

Select “Report
Wizard”.

4.

Click “OK” button.
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Steps of “create a report layout using wizard” 2
5.

6.

7.
8.
9.
10.
11.

Select the name of the table
or query that includes the
data you want to add into the
report from down arrow list.
Select the fields to add into
the report by clicking the “>”
button or click “>>” to add all
fields.
Click “Next” button.
Select the field If you want to
add grouping.
Click “>” button to add.
Change the priority using
arrow sign button if you want.
Click “Next” button.

Steps of “create a report layout using wizard” 3
12. Select

the field from
down arrow list if you
want to sort the records.
13. Select “Ascending” or
“Descending”.
14. Click “Summary Options”
button.
15. Click the check box if you
want to perform
calculations on numerical
fields e.g. Sum, Average
or etc.
16. Click “OK” button.
17. Click “Next” button.
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Steps of “create a report layout using wizard” 4
18.
19.

20.
21.
22.
23.
24.

Select the type of layout
from the list.
Select orientation
“Portrait” or
“Landscape”.
Click “Next” button.
Select the type of style
form the list.
Click “Next” button.
Type the name of report
title in the box.
Click ”Finish” button.

Steps of “creating a report in design view” 1
1.
2.

3.
4.

5.
6.

7.

Click “Report” tab.
Click “New”. (New Report dialog
box is displayed).
Select “Design View”.
In “Choose the table or query
where the object data comes”,
select the table or query form
from down arrow list you wish to
create a form for..
Click “OK” button. (Report design
grid is displayed).
Drag each field from the field list
to the layout grid and drop it
where you want the data column
to appear.
After you place, click “Save”
command on the toolbar. (Save
As dialog box is displayed).
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Steps of “creating a report in design view” 2
8.

Type the name of
the report.

9.

Click “OK” button.

10.

Click “Print Preview”
button to view the
report.

Steps of “modifying a report layout”
1.

2.

3.
4.

5.

Open the report in
design view.
Click report header or
footer you want to
modify.
Make the necessary
changes.
Click “Save” command
on the toolbar to save
the changes.
Click “Print Preview”
command on the toolbar
to view the changes.
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Steps of “add more controls onto the report layout”
1.
2.

3.
4.

5.
6.

Open the report in design
view.
Click “Field List” command on
the toolbar. (field list is
displayed).
Select one or more fields in
the field list.
Add field to design grid using
drag and drop and adjust the
field as you wish.
Click “Save” command on the
toolbar to save the changes.
Click “Print Preview”
command on the toolbar to
view the changes.

Steps of “resize a control”
1.
2.
3.

4.

5.

Click “Report” tab.
Open the report in
design view.
Select the control you
want to resize. (place
holders are displayed
around control).
Place the mouse pointer
on the place holder.
(mouse pointer sign will
be changed to a doublesided arrow sign).
Drag the mouse pointer
to resize the control.
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Steps of “move a control”
1.
2.
3.

4.

5.

Click “Report” tab.
Open the report in
design view.
Select the control you
want to resize. (place
holders are displayed
around control).
Place the mouse pointer
on the place holder until
its sign is changed to a
hand sign.
Drag the mouse pointer
to move the control.

Creating labels


A label is a sticker or piece of paper put on
an item for the purpose of identification.
Examples of stickers are mailing labels,
label on the floppy disk where you write
your name etc. Using the report label
wizard, MS-Access lets you easily create
labels of different sizes.
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Steps of “create a label using the report wizard”
1.
2.
3.
4.

5.
6.
7.

Click the “Report” tab.
Click “New”. (New Report
dialog box is displayed).
Select “Label Wizard” from
the list.
In “Choose the table or query
where the object data
comes”, select the table or
query form from down arrow
list you wish to create a form
for.
Click “OK” button. (Report
design grid is displayed).
Select the size of label you
want to create.
Click “Next” button.

Steps of “creating a label using the report wizard” 2
8.

9.
10.

11.

Select font type,
size, weight and
color.
Click “Next” button.
Select mailing labels
from available field
by clicking “>”
button.
Click “Next” button.
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Steps of “creating a label using the report wizard” 3
12.

13.
14.

15.

Sort labels if you
want by clicking “>”
button or click “>>”
button.
Click “Next” button.
Type the name of
the label in the box.
Click “Finish” button.

Modifying labels


Just as you can modify a report or a form,
you can also modify a label by
manipulating the layout controls
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Steps of “modify a label”
1.
2.

3.
4.

5.
6.

Click “Report” tab.
Click “Design” button. (the
label is displayed in design
view).
Edit the layout as desired
After you modify, click
“Save” command on the
toolbar.
Close the design grid.
Click “Print Preview”
command on the toolbar to
view.

Printing the reports and labels


Before you print a report or a label, you
should first set the page options i.e. the
margins, paper size and orientation.
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Steps of “printing the reports and labels”
1.
2.
3.

4.
5.
6.
7.
8.

Click “Report” tab.
Select the report you want to
print.
Click “Preview” button. (Print
Preview window is
displayed).
On the “File” menu.
Click “Print” (Print dialog box
is displayed).
Select the printer from down
arrow list.
Set other options i.e. print
range and number of copies.
Click “OK” button.

Creating macros


A macro is a set of one or more actions
used to automatically perform particular
operations such as opening a form or
printing and a report. Macros are used to
automate database applications.
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Steps of “creating macros” 1
1.
2.
3.

4.

5.
6.

7.

Click “Macros” tab.
Click “New” button. (Macro window
is displayed).
Add an action e.g. OpenTable into
action column from down arrow
list.
In the lower part, specify
arguments for the action in Action
Argument box.
Type optional comment for the
action if you need.
Add more actions to the macro if
you want. Actions are executed in
the order you list them.
Click “Save” command on the
toolbar to save the macro.

Steps of “creating macros” 2
8.

Type the name of
macro in the box.

9.

Click “OK” button.

10.

Click “Run”
command on the
toolbar to open the
macro.
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Enforcing database security


MS-Access provides the user with several data security
tools.
Password protection – requests the password for opening.
Encryption – compacts a database file and makes in
indecipherable by a utility program or a word processor
especially on a networked environment. Encrypting a database
doesn’t restrict access to objects by users.
C) Hiding database object – hide tables, queries, forms and reports
and macros from casual users. This method of protection is the
least secure because it is possible to unhide the objects.
D) User-level security – this is the most extensive security method
especially on a multi-user environment. A database
administrator can grant specific users or groups specific
permissions and privileges to tables, queries, forms. Reports
and macros.
A)
B)

Steps of “setup a password in MS-Access” 1
1.
2.

3.
4.

5.

6.

Open MS-Access.
On the “File” menu.
Click “Open” (Open dialog
box is displayed).
Click arrow down sign of
“Open” button. (open menu
is displayed).
Open the database in
exclusive mode which you
want to set a password.
(Security Warning dialog box
is displayed).
Click “Open” button.
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Steps of “setup a password in MS-Access” 2
7.
8.
9.

10.
11.

12.

On the “Tool” menu.
Point to “Security”.
Click “Set Database
Password”. (Set a
Password dialog box is
displayed).
Type the unique
password in the box.
Re-type the unique
password in the “Verify”
box.
Click “OK” button.

Steps of “encrypt a database” 1
1.

2.
3.
4.

Start MS-Access without
opening a database
because you can’t
encrypt or decrypt a
database when it is
open.
On the “Tools” menu.
Point to “Security”.
Click “Encode/Decode
Database”
(Encode/Decode
Database dialog box is
displayed).
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Steps of “Encrypt a database” 2
5.

6.

7.

8.

9.

Select the database you
want to encode or
decode.
Click “OK” button.
(Encode Database
dialog box is displayed).
Select the location from
down arrow list to save.
Type the file name in
the “Name box.
Click “OK” button.

Steps of “hide object”
1.
2.

3.

4.
5.

On the “View” menu.
Click “Properties”.
(Properties dialog
box is displayed).
Check in the
“Hidden” box.
Click “Apply” button.
Click “OK” button.
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Steps of “assign user rights and privileges” 1
1.
2.
3.
4.

5.

Open the database.
On the “Tools” menu.
Point to “Security”.
Click “User-Level
Security Wizard”.
(Security Wizard
dialog box is
displayed).
Click “Next” button.

Steps of “assign user rights and privileges” 2
6.

7.

8.

9.
10.

11.

Click “Browse” button.
(Select a workgroup file
dialog box is displayed).
Select the location from
shortcut keys.
Type the name of file in
the box.
Click “Select” button.
Type the unique “WID”
(workgroup ID) in the
box.
Click “Next” button.
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Steps of “assign user rights and privileges” 2
12.

13.
14.

15.

16.

Check in the boxes
which you want to select
the database to help
source from each tab.
Click “Next” button.
Check in the box which
you want to include in
your workgroup
information file.
Type “Group ID” in the
box each groups.
Click “Next” button.

Steps of “assign user rights and privileges” 3
17.

18.
19.

20.

Select “Yes” or “No” to
grant the users group
some permission. If you
select “Yes”, you can
set some option from
each tab.
Click “Next” button”.
You can add users to
your workgroup
information file. If you
want to add, type “User
name’, “Password” and
‘PID” (personal ID) in
the each box.
Click “Next” button.
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Steps of “assign user rights and privileges” 3
21.

22.
23.

24.
25.
26.
27.

Select “Select a user and
assign the user to groups” or
“Select a group and assign
users to the group”.
Click “Next” button.
Click “Browse” button.
(Choose a database name
dialog box is displayed).
Select the location from
down arrow list to save.
Type the “File name” in the
box.
Click “Select” button.
Click “OK” button.

Setting up startup options


To customize your database application
workplace, there is need to specify how
the database is to be loaded.
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Steps of “set the startup options”
1.

2.

3.

4.

On the “Tools”
menu.
Click “Startup”.
(Startup dialog box
is displayed).
Set startup options
e.g. “Application
Title”, “Application
Icon” or etc.
Click “OK” button.

Review questions 1
1.
2.
3.
4.
5.

What is a relational database
management system?
Define the following terms: table, records
and field as used in databases.
State six major objects used to
manipulate data in MS-Access.
Explain how you can start and exit MSAccess.
In MS-Access, what do the following
terms refer to: query, macro, module.

546
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Answer of review questions 1
1.
2.

3.

4.

5.

A relational database is a model where information is stored in
related structures called tables or relations.
Table: a structure used to store related records.
Records: related field that represents a single item or entity.
Field: logical combination of characters that can be manipulated
as a unit.
Objects which help the user easily manipulate and manage data
in a database include:
 Tables, forms, queries, reports, macros, modules.
To start MS-Access, click start, point to programs then click MSAccess. To exit, click file then exit or simply click the close button
on the title bar.
Query: a database feature used to analyse data in a table.
Macro: a feature used to automate database operations.
Module: a programming environment embedded in MS-Access
547
used to automate database operations.

Review questions 2
1.

2.
3.

4.

5.
6.

Differentiate between a primary key and an
index.
What is normalization in reference to tables?
Describe various data types used in MSAccess.
Explain how you would set a validation rule
when designing tables.
What are field properties?
What is the difference between a field name
and a caption?
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Answer of review questions 2
1.

2.

3.
4.

5.
6.

Primary key – unique field used to identify each record uniquely
for easy access and manipulation.
An index – a key not necessarily unique used to arrange data in a
table.
Normalisation – a technique used to make a complex database
more efficient by breaking one large table into smaller related
tables.
Text, number, date/time, logical (yes/no), etc.
Setting validation rule:
A)
Select the field you want to set validation rule to.
B)
In the field properties section, click the insertion pointer in the
validation rule cell.
C)
Type in the validation rule e.g. BETWEN 0 AND 100.
Field properties – characteristics of a field such as size, format,
etc.
Field name is a combination of characters that identifies a data
549
item whereas a caption is a full desc

Review questions 3
1.

2.
3.
4.
5.
6.

Define the following terms:
A) Form;
B) Bound and unbound control;
Differentiate between tabular and columnar form layout.
Explain how you would create a form without using a
form wizard.
Why would one prefer to use a form for data input rather
than entering directly into a table?
Explain how you would move from one record to
another in a form.
Draw a simple sketch of a form that can be used to
enter all subjects marks in an examination database.
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Answer of review questions 3
1.

2.

3.
4.
5.
6.

Form – user interface that helps the user view records and easily
make entries into a table.
Bound controls – data field in a form layout grid that is used to
display data from the underlying table query.
Unbound control – data field in a form layout grid that is not based
on any data source.
Columnar form – display one record at a time with the fields
arranged downwards.
Tabular form – records are displayed across the screen from right to
left.
Click the design view from new form dialog box to display the form
design grid.
To provide an interface that let the user enter and view data easily.
Using the navigation button.
Student to use a word processor to sketch the form layout.
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Review questions 4
1.
2.

3.
4.

5.
6.
7.
8.

Explain two tools you can use to search for data in a database.
What is Referential Integrity?
Differentiate between a table and a query.
Write down the criteria you would use to display employees’
details from a payroll database who earn between 90,000 and
240,000.
Explain how you would sort data in a query.
What is the difference between an action query and a select
query?
Explain what happens when you try to enter invalid data into a
related table for which referential integrity has been reinforced.
Explain how you would create a select query that would be
552
used to calculate your total score and average in ten subjects.
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Answer of review questions 4
1.
2.
3.

4.
5.

6.
7.
8.

Query and find command.
A feature used to eliminate chances of entering non existing data
into child table., that do not exist in the primary table.
A table is a structure used to store related records while a query is a
component used to analyse data in a table.
Between 90,000 and 240,000.
1). Click the cell that you want to use to sort a query in the sort row.
2). From the drop down list, select the sort order, i.e. descending or
ascending order.
Select query is used to search and analyse data in a table while
action query is used to make changes to underlying query or table.
Access gives a warning message and denies the user from entering
the next record.
Insert the totals function in a query then select SUM and AVG.
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Revision questions
1.

2.
3.
4.

5.

What is the importance of a report generated from a
database?
What is the difference between a report and a label?
Explain how you would create a report that displays
subtotals and grand totals.
Dr. Garaya is a pharmacist. She wants to generate
labels that she can use to stick to medicine bottles.
Explain to her how she can generate labels of different
sizes using MS-Access database.
Assuming you have been appointed as the sales
representative of an insurance company, explain how
you would create annual reports that would include the
company logo at the top of every page.
554
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Answer of revision questions
1.
2.

3.

4.
5.

Report – used to give a summarised information for the
purpose of presentation.
A report gives a summarised information for the
purpose of presentation while a label is a sticker placed
on an item for the purpose of identification or
description.
To create a report that displays subtotals and grand
totals, click summary options button in the report wizard
or create calculated controls in the report design grid in
the grouping field footer and report footer respectively.
Macros and modules.
See creating reports. To insert logo and drop it in the
page header in the report design grid.
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Practical activity 1


Field Name

Data Type

ID Number

Text

Last name

Text

First name

Text

Address

Text

Town

Text

Company

Text

Date

Dates/Time

Salary

Currency

Married?

Yes/No

Create a database
called Employees and
in it create a table
called customers with
the right fields:
a.
b.

Save the Table as
CUSTOMER.
In the description
column, which is
optional, describe what
each field is for, e.g. ID
Number is the number
that identifies each
employee uniquely.556
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Practical activity 2
A)

B)

In the database, create
a table called DVDs
with the right attributes:
Determine the following
in A above.
i.
ii.
iii.

C)

The primary key;
The missing data types
and properties;
Field captions.

Enter ten records into
557
the table.

Practical activity 3-1
Field name
Student number
First name

Data type
Text
Text

Last name
Maths
Physics
Chemistry
Computer Science
Total
Position
Reporting Date

Text
Number
Number
Number
Number
Number
Number
Date/Time



Create a table
named Exams in
a COLLEGE
database with the
fields:
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Practical activity 3-2


Set the Student number as the primary key.
Using a data form, enter data for five students as
follows.

Student No. MATHS PHY CHEM COMPUTER
2001

40

50

40

90

1983

60

70

57

30

2002

80

30

37

70

1513

30

63

80

70
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Practical activity 3-3


Without using the form wizard, create a form for
the exams table such that the format is
displayed as below:

Student Name ………. Student Name ………. Total ……….
Position ……….
Reporting Date ……….
Subject
Average Marks
Maths
……….
Physics
……….
Chemistry
……….
Computer
………..
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Practical activity 4-1


1.

You Are the database manager, Riceland
SACCO society and you are expected to create
a database called Riceland.
Design two tables in the database, employees
and bill with the following fields:
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Practical activity 4-2


Enter the following records in the employees’ table:

PNo National
ID
201 12234
203 22734
207 22734
208 12234

First
Name
Ali
Alice
Daniel
Pateicia

Last
Name
Mohamed
Korir
Karimi
Atieno

Date
Employed
16-3-2002
16-5-2002
16-3-2003
16-3-2004

Salary

Sex

40000
37000
60000
38000

M
F
M
F
562
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Practical activity 4-3


Enter the following records in the bills table

PNo
201
203
201
208
204

Bill No
1100
1200
2000
1340
1430

Date Employed
9-7-2004
16-7-2004
24-7-2004
16-6-2004
18-7-2004

Salary
3,000
7,000
2,000
800
1,700
563

Practical activity 4-4


Create a calculated query based on the
two tables that will calculate and display
the following:
A)

The total bill for Joe in the month of January

B)

The total bill for all the employees.
564
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Practical activity 5
1.

Open the Riceland database and generate a report that
displays the following:
Employee name, the gross salary, allowances and the net pay.
Subtotals and grand totals for all the employees.
3. The current date and time.
1.
2.

2.

You have been requested by the School Principal to create a
school database that includes the following:
Four departments (Maths, Science, Humanities and Technical subjects);
Members of staff in each department;
3. Subjects offered in a department.
1. From the database, generate a grouped report for all members of
staff in each department.
2. Create labels to be placed at the door of every head of department’s
office.
565
1.
2.

Chapter 6
Desk Top Publishing (DTP)

566
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Introduction


Desktop publishing is application software
used in producing publication work within
the computer framework of art and design.
Microsoft Publisher is gaining ground due
to its ease of use like other Microsoft
Office programs.
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Samples of publication
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Examples of publications


Cards



Newspaper



Posters



Calendars



Brochures



Newsletter etc.
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Desktop publishing can be used in
Designing texts and images
 Producing publications
 Creating illustrations
 Editing texts and graphics
 Composing templates


570
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Purpose of desktop publisher






Graphics design – a typesetter can create and
edit very complex text and graphical objects like
pictures to finest details.
Page layout design – the user can be able to
design a page layout by setting consistent
picture and objects locations dividing page in a
number of columns and creating layer.
Printing – the main purpose of desktop publisher
is to produce publications, therefore it helps the
user prepare what is referred to as an artwork in
commercial circles for printing.
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Types of desktop publishing software
Graphical based – they are specifically
developed to edit and format graphic
objects like pictures e.g. Adobe Photoshop,
Coral draw, Harvard graphic etc.
 Layout based – these types of desktop
publishers are specifically developed to
create different page layout designs for
text and pictures e.g. MS-Publisher,
Adobe PageMaker etc.
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MS-Publisher 2003 window

573

Parts of MS-Publisher window 1
1.

2.
3.
4.

Paste board – it’s a large blank area where you
place text and graphical objects before arranging
them on the printable area.
Printable area – it’s the area surrounded by
margins on the pasteboard.
Tool box – it’s a set of buttons that contains various
tools used to create and manipulate publication.
Master page icon – it’s placed at the bottom of the
publication window and holds icons representing
each page in the publication. A master page is
used to design the general layout that needs to be
applied in all other pages of the publication.
574
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Parts of MS-Publisher window 2
5.

6.

7.

Rulers – they help the user to manually create
ruler guides, which are nonprinting extensions
and also to measure an object size.
Control palette – it’s a shortcut tool bar mainly
having text and paragraph formatting
commands icons.
Tracking and kerning – tracking refers to
changing the visual denseness or openness of
character in a line while kerning is fixing
particular pair of letters that is too close or too
far apart from each other.
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Tool of MS-Publisher 2003
1.

2.

3.
4.

5.

6.

Select Objects – select,
move and resize text blocks
and graphical objects.
Horizontal and Vertical Text
Box – insert text boxes.
Insert Table – insert tables.
Insert WordArt – insert
wordarts.
Picture Frame – create a
frame for paste a picture.
Line – draw straight lines
576
any direction.
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Tool of MS-Publisher 2003
7.

8.

9.

10.

11.

Arrow – draw straight arrow
lines any direction.
Oval – draw ovals
autoshape.
Rectangle – draw squares
and rectangles.
Autoshape – insert other
types of autoshape.
Design Gallery Object –
insert design gallery objects.
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Steps of “Starting Publisher 2003”
1.

2.

3.

4.

From the “Start”
menu.
Point to “Programs/All
Programs”.
Point to “Microsoft
Office”.
Click “Microsoft Office
Publisher 2003”.
(Publisher window is
displayed).
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Steps of “open the new print publication from design template

1.

2.

Select a category of
design templates
from task pane e.g.
“Publications for
print”, “Web Site and
E-mail” or etc.
Click a template you
want to create from
the list. (Template is
displayed).

Steps of “open the new blank print publication 1
1.

2.
3.

4.
5.
6.

Click “New” command on
the standard toolbar. (New
blank print publication is
displayed).
On the “File” menu.
Click “Page Setup” (Page
Setup dialog box is
displayed).
Select publication type from
the list.
Select orientation “Portrait”
or “Landscape”.
Click “OK” button.
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Steps of “open the new blank print publication” 2
7.
8.

9.
10.

11.

On the “Arrange” menu.
Click “Layout Guides”.
(Layout Design dialog
box is displayed).
Set each margins.
Set other properties
from each tab.
Click “OK” button.

NB; shortcut key of “New”
Ctrl + N

Steps of “set up a publication in Publisher”
1.
2.
3.

4.

On the “View” menu.
Click “Master Page”. (master
page window is displayed).
Use the “Edit Master Pages”
toolbar to design a master
page.
Click “Close Master View”
button on the toolbar to switch
view back to foreground
pages.

NB; shortcut key of switch to
“Master page”
Ctrl + M
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Steps of “add text using text frame tool in Publisher”
1.
2.

3.
4.

Click tool marked “A” on the
tool box.
Select an empty area on the
pasteboard or printable area
to add text frame and create
it using drag and drop.
Click inside of the text frame.
Type the text in the text
frame.

NB; text may not fit in the created
text frame. Publisher displays
A… below the text frame.

Steps of “resize the text block”
1.

2.

3.

4.

Click “Select Object”
command on the
object toolbar.
Click text block you
want to resize.
Place the pointer on
the handle.
Drag and drop to
resize.
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Steps of “move the text block”
1.

2.

3.

4.

Click “Select Object”
command on the object
toolbar.
Click the text block you
want to move.
Place the pointer on the
outline of text block and
hold down the left mouse
button.
Drag the text object to a
new position then drop.

Importing functions


Importing text from a word processor –
other than typing you can also import text
from a word processor file.



Inserting graphical objects – you can
import pictures and other graphical objects
into a publisher document by linking or
embedding.
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Steps of “importing text from a word processor
1.
2.

3.

4.
5.

On the “File” menu.
Click “Import Word
Document”. (Import Word
Document dialog box is
displayed).
Select the location where
document is existing from
shortcut command.
Select the document.
Click “OK” button. (the text
is pasted onto the printable
area.

Steps of “inserting graphical objects”
1.
2.
3.

4.

5.

6.

On the “Insert” menu.
Point to “Picture”.
Click “From File”. (Insert
Picture dialog box is
displayed).
Select the drive or folder
from shortcut menu
where the file is located.
Select picture you want
to insert.
Click “Insert” button.
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Steps of “embed or link an object”
1.
2.
3.
4.
5.

6.
7.
8.

9.

On the “Insert” menu.
Click “Object”. (Insert Object
dialog box is displayed).
Select “Create from File”.
Click “Browse” button. (Browse
dialog box is displayed).
Select the drive or folder from the
shortcut menu where the file is
located.
Select the file you want to link or
embed.
Click “OK” button.
Check into the link check box to
link. For embedding leave the box
unchecked.
Click “OK” button.

Steps of “delete text in publisher”
1.

Click “Select Object”
command on the
object toolbar.

2.

Highlight the text
you want to delete.

3.

Press “Delete” or
“Backspace” key.

295

Steps of “delete a text object”
1.

Click “Select Object”
command on the object
toolbar.

2.

Click the text object you
want to delete. (handles
are displayed around
picture).

3.

Press “Delete” or
“Backspace” key.

Steps of “copy a block of text”
1.

2.
3.
4.
5.
6.
7.

Click “Select Object”
command on the object
toolbar.
Highlight the block of text.
On the “Edit” menu.
Click “Copy”.
On the “Edit” menu.
Click “Paste”.
Move the copied block of text
where you want to paste.

NB; shortcut key of “Copy”
Ctrl + C
shortcut key of “Paste”
Ctrl + V
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Steps of “move a block of text”
1.

2.
3.
4.
5.
6.
7.

Click “Select Object”
command on the object
toolbar.
Highlight the block of text.
On the “Edit” menu.
Click “Cut”..
On the “Edit” menu.
Click “Paste”.
Move the block of text where
you want to paste.

NB; shortcut key of “Cut”
Ctrl + X
shortcut key of “Paste”
Ctrl + V

Steps of “spell check a publication”
1.
2.
3.

4.
5.

6.

On the “Tools” menu.
Point to “Spelling”.
Click “Spelling”. (Check
Spelling dialog box is
displayed).
Select correct spell of word
from suggestions.
Click “Change” button. If you
want to ignore suggestions,
click “Ignore” button.
After you check, close this
dialog box from “Close”
button.

NB; shortcut key of spelling
F7
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Steps of “find and replace”
1.
2.

3.
4.

5.

On the “Edit” menu.
Click “Replace”. (Find and
Replace task pane is
displayed).
In the “Find What” box, type
the word(s) to be searched.
In the “Replace With” box,
type the word(s) to replace
the found word(s).
Click “Find Next” or
“Replace”, “Replace All”
button.

NB; shortcut key of “Replace”
Ctrl + H

Steps of “edit a publication layout”
1.
2.

3.

4.

On the “View” menu.
Click “Master Page”.
(master page window is
displayed).
Make the necessary
changes using master
page toolbar.
Click “Close Master
View” button to close
master page window.
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Editing graphical objects


Graphical objects are clip arts and
pictures. You edit object attributes such as
size, position, colour and brightness.

Steps of “edit objects attributes”
1.

Click “Select Object”
command on the
object toolbar.

2.

Select the object you
want to edit. (picture
toolbar is displayed).

3.

Adjust the required
attributes.
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Formatting a publication


Formatting refers to applying special
effects or attributes to the layout, text and
graphical objects.

Steps of “format text” in Publisher
1.

Click “Select Object”
command on the
object toolbar.

2.

Highlight the text to
be formatted.

3.

On the formatting
tool bar, choose font
style, size and other
attributes.
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Steps of “format text to superscript”
1.

2.

3.
4.

5.

6.

Click “Select Object”
command on the object
toolbar.
Highlight the text to be
superscripted.
On the “Format” menu.
Click “Font” (Font dialog
box is displayed).
In the “Effects” section,
check in the box of
“Superscript”.
Click “OK” button.

Steps of “format text to subscript”
1.

2.

3.
4.

5.

6.

Click “Select Object” on
the object toolbar.
Highlight the text to be
subscripted.
On the “Format” menu.
Click “Font” (Font dialog
box is displayed).
In the “Effects” section,
check in the box of
“Subscript”.
Click “OK” button.

301

Paragraph and page formatting


Paragraph formatting involves aligning
text, indenting, adding column guides,
inserting headers and footers.
column guides – by default, a page
is made up of one column.
 Headers and footers – headers are lines of
text, page numbers or dates that appears at
the top of every page. Footers on the other
hand, appear at the bottom of every page.
 Inserting

Steps of “create more than one columns”
1.
2.

3.
4.

5.

On the “Arrange” menu,
Click “Layout Guides”.
(Layout Guides dialog
box is displayed).
Click “Grid Guides” tab.
In the “Column Guides”
section, enter number
of columns required.
Click “OK” button.
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Steps of “insert headers and footers”
1.
2.
3.

4.

5.

6.

Press Ctrl + M keys to
switch to master page.
On the “View” menu.
Click “Header and Footer”
(Header and Footer toolbar
is displayed).
Insert date or time from
each command on the
header and footer toolbar.
Type words if you want to
insert to the header or
footer.
After you insert, press again
“Ctrl + M” keys to close to
master page window.

Steps of “insert page numbers”
1.
2.

3.

4.

5.

On the “Insert” menu.
Click “Page Numbers”
(Page Number dialog
box is displayed).
Select position to insert
page numbers from
down arrow list.
Select alignment to
insert page numbers
from down arrow list.
Click “OK” button.
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Formatting graphical objects








Fill and stroke – filling refers to applying a solid
colour or patterns to a drawing, while stroke
refers to line style.
Arranging objects – if an object is hidden by
another, you need to rearrange them in order of
priority.
Cropping graphical objects – cropping refers to
hiding unwanted parts of a graphical object
particularly in a picture.
Grouping objects – if you have several objects in
a publication, you may want to group them
together.

Steps of “apply background and stroke”
1.

2.
3.
4.

5.

6.

7.

Click “Select Object”
command on the object
toolbar.
Select the object you want to
apply.
On the “Format” menu.
Click “AutoShape”. (Format
AutoShape dialog box is
displayed).
In the “Fill” section, select
colour you want to fill from
arrow down list.
In the “Line” section, select
outer line of colour, style or
etc from down arrow list.
Click “OK” button.
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Steps of “rotating an object”
1.

2.

3.
4.
5.

Click “Select Object”
command on the object
toolbar.
Select the object you
want to rotate. (handles
are displayed around
object).
On the “Arrange” menu.
Point to “Rotate or Flip”.
Click one you want to
apply to rotate e.g. “Free
Rotate”, “Rotate Left
90°” or etc.

Steps of “arrange objects (Bring to Front)”
1.

2.

3.
4.
5.

Click “Select Object”
command on the object
toolbar.
Select the object you
want to bring to the
front.
On the “Arrange” menu.
Point to “Order”.
Click Bring to Front”.

NB: shortcut key of “Bring to
Front”
Alt + F6
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Steps of “arrange objects (Send to Back)”
1.

2.

3.
4.
5.

Click “Select Object”
command on the object
toolbar.
Select the object you
want to bring send to
the back.
On the “Arrange” menu.
Point to “Order”.
Click “Send to Back”.

NB; shortcut key of “Send to
Back”
Alt + Shift + F6

Steps of “crop an object”
1.

2.

3.

4.
5.

Click “Select Object”
command on the object
toolbar.
Select the object you
want to crop. (Picture
toolbar is displayed).
Click the “Crop”
command on the picture
toolbar. (placeholder is
displayed around
picture.
Place the mouse pointer
on the placeholder.
Drag inward up to you
want to crop.
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Before and after cropping

Steps of “group objects”
1.

2.
3.
4.

5.
6.

7.

Click “Select Object”
command on the object
toolbar.
Select a object to be
grouped.
Hold down “Ctrl” key.
Select other objects to be
grouped with you already
selected.
Release “Ctrl” key.
Right click on the picture
which you selected.
(shortcut menu is displayed).
Click “Group”.
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Steps of “wrapping text”
1.
2.
3.
4.
5.
6.

7.
8.

Click “Select Object”
command on the toolbar.
Select object placed on the
text box.
On the “Format” menu.
Click “Picture”. (Picture dialog
box is displayed).
Click “Layout” tab.
In the “Wrapping Style”
section, select one you want
to apply e.g. Square, Tight or
etc.
Set other options if you want.
Click “OK” button.

Samples of wrapping style
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Steps of “printing a publication” 1
1.
2.
3.

4.
5.

6.
7.
8.

On the “File” menu.
Click “Print” Preview”. (Print
Preview window is displayed).
Click “Print” command on the
toolbar. (Print dialog box is
displayed).
Select printer from down arrow list.
Click “Properties” button.
(Properties dialog box is
displayed).
Set print options from each tab e.g.
Page size, Orientation or etc.
Click “OK” button.
In the “Print” dialog box, click
“Advanced Print Setting”.
(Advanced Print Setting dialog box
is displayed).

Steps of “printing a publication” 2
9.

10.
11.

12.

In the “Separate” tab, select
“Separate” from down arrow
list of “Output” to process
cyan, magenta, yellow and
black (CMYK) separately.
Click “OK” button.
In the “Print dialog box, set
other options “Print range”
and “Number of copies.
Click “OK” button.

NB; shortcut key of “Print”
Ctrl + P
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Review questions 1
1.
2.
3.

4.

5.
6.
7.
8.
9.
10.

What is desktop publishing?
Why is a desktop publisher preferred in designing documents than a word
processor.
Give three examples of desktop publishing software available in the market
today.
You have been requested as the patron of journalism club to design for
them a 5 page school magazine. The magazine layout should display the
school logo at the top of every page. Explain how you would achieve this.
What are Master pages?
What is layering as used in DTP? Why is it a very useful feature in a
desktop publisher.
Differentiate between the pasteboard and printable page.
Explain the importance of each tool on MS-Publisher’s toolbox.
What commands are used in place of portrait and landscape page
orientation in MS-Publisher?
What are the three main purposes of a desktop publishing software?
619

Review questions 2
1.
2.
3.
4.
5.
6.

What are non-printing guides?
Give three nonprinting guides used in MSPublisher.
Explain how you would create different
columns on the same page.
What does the term gutter mean in relation to
column setting?
Differentiate between margin guides and
column guides.
Explain how you would lock column guides to
avoid accidental moving from the current
position.
620
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Review questions 3
1.

Explain how you would create text using
A)
B)

2.

3.
4.
5.

Explain how you would draw a hexagon.
What is a text frame? How would you convert a rectangular
shape into a text frame so that you can place text in it.
What is a Control Palette?
Explain how you would use a Control Palette to format;
A)
B)

6.

Text tool;
Text frame;

Characters in a text;
Paragraphs;

Differentiate between the following:
A)
B)
C)

Kerning and tracking;
Change case and drop cap;
Fill and stroke.
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Review questions 4
1.
2.

3.
4.
5.
6.
7.
8.
9.

10.

Give three methods that are used to transform an object.
Explain how you would rotate an object.
How would you lock an object din order to preserve
your publication design?
Explain how you would import an object from another
file using the Place command.
How would you group objects so that you can
manipulate them as a unit?
What is text wrap? Give three ways you can wrap text
on an object.
Define the term cropping.
Explain how you can rotate a triangle by 30 degrees.
What is object grouping.
Explain the concept of wrapping text around objects. 622
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Revision questions 1
1.
2.
3.

4.

5.
6.
7.
8.
9.
10.

Define the term artwork.
What is publishing? How is desktop publishing unique compared to
word processing?
List any four application window layout components found in a
typical desktop publisher.
Explain the function of each of the following tools;
A) Pointer
B) Text
C) Rectangle tool
D) Rotate
Explain the importance of master pages.
Differentiate between margins and column guides.
How can you calibrate rules to measure in millimetres?
Explain how you can draw a triangle of height 5 cm and base 6 cm.
Why do you need to lock margins or objects in a publication?
623
Explain terms font style and line stroke.

Answer of revision questions 1-1
1.
2.
3.
4.

5.
6.

It is a publication that is ready for printing.
The design and production of text and graphics layouts
in mass.
Printable area, paste board, rulers and menu bar.
A). Selects text and graphic objects.
B). Inserts and selects text in the application.
C). Drawing rectangles.
D). Moves objects around a fixed focal point
Helps user set general layout options that apply to all
pages in the publication.
Margins mark text areas on the page along the edges
while column guides divide the page into several fields.
624
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Answer of revision questions 1-2
7.
8.

9.
10.

Right click a ruler then select millimetres.
Drag ruler guides on the screen to mark a
rectangle area of 5cm x 6 cm on the screen.
Draw a rectangle in the guides. Select the
rectangle and then click element followed by
polygon setting dialog box, select 3 sides then
click OK.
To hold them in place in order to avoid losing
the format.
Font style – the size, boldface, italics of font etc.
Line stroke – thickness of a line.
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Revision questions 2
1.
2.
3.
4.
5.
6.
7.
8.
9.

Explain how you can import a graphic into a publication.
To change the page orientation to wide, click ( ) then
( ) and select ( ) from the dialog box.
To fill a polygon, click ( ) then select ( ) and ( )
from the ( ) dialog box.
Rotating means changing the ( ) of an object.
The ( ) tool is used to change the zoom settings of the
application window.
( ) means cutting off the unwanted edges of a graphic
object.
The small black objects that appear around a selected
graphic are called ( ).
Expert tracking means ( ) while kerning means ( ).
How can you change the bold face and font size of
626
selected text at once?
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Answer of revision questions 2
1.

2.

3.
4.
5.
6.
7.
8.

9.

Click File then Place command. Browse for the file. Double
click its icon. The mouse pointer changes to become a loaded
icon. Click anywhere on the pasteboard to place the graphic.
File – Document setup – Wide – Document setup.
Element – Fill and colour type – Fill and stroke dialog box.
Angular placement.
Zoom.
Cropping.
Place holders/handles.
Changing visual denseness by fixing space between a pair of
characters.
Fixing particular pairs of letters that are too close or too far
apart from each other.
627
Using available style.

Practical activity 1


Complete the school magazine so that it will be
a multiple page document with the following
sections:
1. School History.
2. Administrative structure.
3. What is offered in every academic
department.
4. School performance in national
examinations for the last two years.
5. Games and clubs.
628
6. Jokes and entertainment.
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Practical activity 2
1.

Draw the following basic shapes:
A)
B)
C)

2.

Draw a circular text frame and fill it with the following text:
1.

3.

5 cm by 7 cm rectangle;
A circle with 6 cm radius;
A hexagon.
“Computer Studies is relatively a new area of study, which is very
dynamic. Due to this reason, every one of us is expected to keep
abreast with changing trends in Information Communication and
Technology (ICT)”.

Format the character in bold into superscript or subscript:
A)
B)
C)
D)
E)

H20
CM2
NH4OH
1 x 103
Fe3O
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Practical activity 3
1.

Draw the following basic shapes:
A)
B)
C)

2.

An 8 cm square and rotate it to 45 degrees;
Draw a triangle with rounded corners and
apply fill and stroke.
A Star with 74 degrees inset and ten sides.

Insert a clipart from Microsoft clipart
gallery into a publication and crop it to fit
in a 2 cm * 2 cm marked area of the
screen bounded by ruler guides.
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Practical activity 4
1.

Print a copy of your school magazine
that you have developed.

2.

Using a logo provided by the teacher,
measure and design it in a desktop
publishing software and then print it.
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END
632
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